summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-19 07:53:20 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-19 08:18:06 +0200
commit0311bd2876cec779fd54a27a98e0656421c9320d (patch)
tree3e2521c3d3e144aebb393d051ad442fd29a4413b /xfce-base/thunar
parentsys-fs/zfs-kmod: update live ebuild, make build verbose (diff)
downloadgentoo-0311bd2876cec779fd54a27a98e0656421c9320d.tar.gz
gentoo-0311bd2876cec779fd54a27a98e0656421c9320d.tar.bz2
gentoo-0311bd2876cec779fd54a27a98e0656421c9320d.zip
xfce-base/thunar: Bump to 1.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-1.8.6.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index ac73bbc8cce0..9d1c56781f51 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -2,3 +2,4 @@ DIST Thunar-1.6.16.tar.bz2 1977562 BLAKE2B efad6b45a64c5c80bff3d829207a1a0b45b4b
DIST Thunar-1.6.17.tar.bz2 1995398 BLAKE2B c6bc0ebc29cdf8b0d3d184fd5b5019bb6f4caa4e43e16237325ae938e95c077198801e7f0d5210c458e316e0c7f35aa735f8e5bca61372c3cb2f5cf40b78c59a SHA512 2ace85994af51e1651b1e58c4436b5d4a986e75ef56f85c765e7dad8698681a73e009feafff0c9e056153b13c37b915a43529451960a209ae7e0bc23544492b8
DIST Thunar-1.8.4.tar.bz2 2349249 BLAKE2B 4f1ac9c3177587b5ff2f3acd7220fb08921fc9db9711dd5925b65068db9bb14e7cf9d17834a96395c3fc27927030dbd2ba70d08c5b14d28e4aaf553493bce5f2 SHA512 886c0789aa19c2ab2ef34892c4afd09c857585b4796140ea3c84ccb9e1e1ca2935cf7e3a760a6ca8d8c68a5866663412500b4779878c7f48c9365c3ac7bf0eec
DIST Thunar-1.8.5.tar.bz2 2303914 BLAKE2B e47e3e635e883ea4d044c8a66014bc11f21da780b1d834f25678763ace0609ee77755fc04b6a437f238275b0a9bf8df485cc826a6bfef93751427ee93d7e43ac SHA512 491f1a69cc1e825c9c2493af719ba22811d1300f1dfe06e98c45c878649921608d14c08e4f61551dfa3d5227ea0b0af6abad1c953d6fe4b9274ade76bc33e6cc
+DIST Thunar-1.8.6.tar.bz2 2317253 BLAKE2B ee992640e1c3df64f7aad13390a263e4599c9f0a19640b77bf5383ab6f93898f8785c86bbe307da9158390aa435699eb9a70ea3a96fb82d3b726db657436ce52 SHA512 086dc139627d8f11341b2db91358ef1831d2b8494d34abac49355dbaf850a21c30f979294f9adf2bc8548e5f817a4e165803a3db74cd989cd3867a4e228d74db
diff --git a/xfce-base/thunar/thunar-1.8.6.ebuild b/xfce-base/thunar/thunar-1.8.6.ebuild
new file mode 100644
index 000000000000..453b51539055
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.8.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+MY_P=${P^}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre test +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42:=
+ >=x11-libs/gdk-pixbuf-2.14:=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/exo-0.12:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( virtual/libgudev:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}