summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-base/thunar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/Manifest2
-rw-r--r--xfce-base/thunar/metadata.xml8
-rw-r--r--xfce-base/thunar/thunar-1.6.10-r1.ebuild69
-rw-r--r--xfce-base/thunar/thunar-1.6.10.ebuild73
-rw-r--r--xfce-base/thunar/thunar-1.6.3.ebuild72
5 files changed, 224 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
new file mode 100644
index 000000000000..4f013ead8fef
--- /dev/null
+++ b/xfce-base/thunar/Manifest
@@ -0,0 +1,2 @@
+DIST Thunar-1.6.10.tar.bz2 1948762 SHA256 7e9d24067268900e5e44d3325e60a1a2b2f8f556ec238ec12574fbea15fdee8a SHA512 56f9407907c85a631b390b6bf363ee863b5a126afc32e1b10e34434b997e82b86223737a0b0a1a8faf801258ad1cfa0585c9c3537c167f6968a2c4dac458395a WHIRLPOOL 813e3a1628227fbe27d221739e4946aa38b147ff4b165ff915b6a57b38ae544f54dc8facf19af0519fac5e903924459a34b6372c42985ed00e997e02434f4b71
+DIST Thunar-1.6.3.tar.bz2 1983127 SHA256 9a2706f6881ac29cda9f0b0325d179153bc09e37bcbafcab9823c1c1ec89579d SHA512 17ff9c416a11cef2def6c2f2e1623bcfe480131aa466d55c06f81772781178f6d4bab431d9906be58e391c86f2ab0c7096728961643e2091d6ab785188490382 WHIRLPOOL 68590950513fe60a1b03fea08b4fb6d5bb4494373b27076e524d12fd3af62cd81e57818f3df8b1e15c247aba038a5b4472e0222c07203b7826267c5ae7bc469f
diff --git a/xfce-base/thunar/metadata.xml b/xfce-base/thunar/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-base/thunar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-base/thunar/thunar-1.6.10-r1.ebuild b/xfce-base/thunar/thunar-1.6.10-r1.ebuild
new file mode 100644
index 000000000000..4337332cdcd4
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.6.10-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit virtualx xfconf
+
+MY_P=${P/t/T}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/ http://thunar.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+dbus debug exif libnotify pcre test udisks +xfce_plugins_trash"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30:=
+ >=x11-libs/gdk-pixbuf-2.14:=
+ >=x11-libs/gtk+-2.24:2=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10.1:=
+ >=xfce-base/xfconf-4.10:=
+ dbus? ( >=dev-libs/dbus-glib-0.100:= )
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ udisks? ( virtual/libgudev:= )
+ xfce_plugins_trash? ( >=xfce-base/xfce4-panel-4.10:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ dbus? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )
+ xfce_plugins_trash? ( ${GVFS_DEPEND} )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+REQUIRED_USE="xfce_plugins_trash? ( dbus )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable dbus)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ $(use_enable exif)
+ $(use_enable pcre)
+ )
+
+ use xfce_plugins_trash || XFCONF+=( --disable-tpa-plugin )
+
+ DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/xfce-base/thunar/thunar-1.6.10.ebuild b/xfce-base/thunar/thunar-1.6.10.ebuild
new file mode 100644
index 000000000000..e0e6d9042280
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.6.10.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit virtualx xfconf
+
+MY_P=${P/t/T}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/ http://thunar.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+dbus debug exif libnotify pcre test udisks +xfce_plugins_trash"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30:=
+ >=x11-libs/gdk-pixbuf-2.14:=
+ >=x11-libs/gtk+-2.24:2=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10.1:=
+ >=xfce-base/xfconf-4.10:=
+ dbus? ( >=dev-libs/dbus-glib-0.100:= )
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ udisks? ( virtual/libgudev:= )
+ xfce_plugins_trash? ( >=xfce-base/xfce4-panel-4.10:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ dbus? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )
+ xfce_plugins_trash? ( ${GVFS_DEPEND} )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+REQUIRED_USE="xfce_plugins_trash? ( dbus )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable dbus)
+ # no code uses this, it's all in libxfce4ui now
+ # https://bugzilla.xfce.org/show_bug.cgi?id=11837
+ --disable-startup-notification
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ $(use_enable exif)
+ $(use_enable pcre)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ use xfce_plugins_trash || XFCONF+=( --disable-tpa-plugin )
+
+ DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/xfce-base/thunar/thunar-1.6.3.ebuild b/xfce-base/thunar/thunar-1.6.3.ebuild
new file mode 100644
index 000000000000..ceea193badd7
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.6.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit virtualx xfconf
+
+MY_P=${P/t/T}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/ http://thunar.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+dbus debug exif libnotify pcre startup-notification test udisks +xfce_plugins_trash"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-2.24:2
+ >=xfce-base/exo-0.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10.1
+ >=xfce-base/xfconf-4.10
+ dbus? ( >=dev-libs/dbus-glib-0.100 )
+ exif? ( >=media-libs/libexif-0.6.19 )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6 )
+ startup-notification? ( x11-libs/startup-notification )
+ udisks? ( virtual/libgudev:= )
+ xfce_plugins_trash? ( >=xfce-base/xfce4-panel-4.10 )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ dbus? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )
+ xfce_plugins_trash? ( ${GVFS_DEPEND} )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+REQUIRED_USE="xfce_plugins_trash? ( dbus )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable dbus)
+ $(use_enable startup-notification)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ $(use_enable exif)
+ $(use_enable pcre)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ use xfce_plugins_trash || XFCONF+=( --disable-tpa-plugin )
+
+ DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+}
+
+src_test() {
+ Xemake check
+}