summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-24 21:17:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-24 21:51:37 +0200
commit1de96b14cd0b6422c8934c23a40de7d771e5e5ba (patch)
tree1d336e1935b667fc362da998aaa403d1d64d4d86 /xfce-base
parentdev-python/pycparser: skip tests if cpp is not in PATH (diff)
downloadgentoo-1de96b14cd0b6422c8934c23a40de7d771e5e5ba.tar.gz
gentoo-1de96b14cd0b6422c8934c23a40de7d771e5e5ba.tar.bz2
gentoo-1de96b14cd0b6422c8934c23a40de7d771e5e5ba.zip
xfce-base/thunar: Bump to 1.8.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-1.8.15.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 8bdfdd04ce00..5e49aef44d3e 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,3 @@
DIST thunar-1.8.12.tar.bz2 2367685 BLAKE2B 259e7a2c9aeb66673a7b5e6d7147d5257d64b7143c79981ee65097568505969426ea4b20e7ef754fcc6f03e19f632b078115d2db524f2a6eeec1f1e3253e14e4 SHA512 cd27b26796602ea8623c368cd6c8bb53136c09e4a02c37775bed9918c801741e0adb5784151fbf4b93785967a637ffb8b1214b0721f9457de683ebd7718a8767
DIST thunar-1.8.14.tar.bz2 2373742 BLAKE2B 32cdc316defaf781e705ecd9e0550014e1270f09e8eb914f164df4bc557c433fcedbcfb41e200faf317bbab96a20275e4416945050cb10981ee68e0f0cdd357d SHA512 ce6da526e6378ffc90686f6ae25e56109e8af7d0c592345aca3de4603f4c5b3d089255bc313f2a60ee454cc3f0af52106584663c72ecd542a9c92769559c6787
+DIST thunar-1.8.15.tar.bz2 2366401 BLAKE2B 2d594ccf4e0eb68fd9f1129b2d737121982ed4275265ea26866c766755f717cfa197abf89ff9d3c07403a71b7feb29ccfabb14e935ec08fab418b173c39fd8f6 SHA512 50020084105daf5d5464cdcd29827fa212b121b0f6a385b6e2820fd120b6880cffafe63f51e737bc33d13f174f83de5c165f2ce155ff6aae74cc1b285cbdc8db
diff --git a/xfce-base/thunar/thunar-1.8.15.ebuild b/xfce-base/thunar/thunar-1.8.15.ebuild
new file mode 100644
index 000000000000..80545f3c2e18
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.8.15.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-0.12:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}