summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-08-15 23:22:01 +0800
committerJason Zaman <perfinion@gentoo.org>2016-08-15 23:23:16 +0800
commit2886d997e951be795ef11f37e837254a0273732a (patch)
tree3f46160d40af9bc7eec14dc4ea65c7d01e22f87f /xfce-base
parentMask exo-0.11.0-r1 also (diff)
downloadgentoo-2886d997e951be795ef11f37e837254a0273732a.tar.gz
gentoo-2886d997e951be795ef11f37e837254a0273732a.tar.bz2
gentoo-2886d997e951be795ef11f37e837254a0273732a.zip
xfce-base/exo: Add patch to preserve environment
Package-Manager: portage-2.2.28
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/exo-0.11.0-r1.ebuild45
-rw-r--r--xfce-base/exo/files/exo-0.11.0-env.patch26
2 files changed, 71 insertions, 0 deletions
diff --git a/xfce-base/exo/exo-0.11.0-r1.ebuild b/xfce-base/exo/exo-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..824d3e9220f8
--- /dev/null
+++ b/xfce-base/exo/exo-0.11.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30:=
+ dev-perl/URI
+ >=x11-libs/gtk+-2.24:2=
+ >=x11-libs/gtk+-3.6.0:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=( ${FILESDIR}/${P}-env.patch )
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ # both required for GTK+3 support
+ # (non-GTK+3 variant fails to build, as predicted)
+ --enable-gtk3
+ --enable-libxfce4ui2
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}
diff --git a/xfce-base/exo/files/exo-0.11.0-env.patch b/xfce-base/exo/files/exo-0.11.0-env.patch
new file mode 100644
index 000000000000..67ad54fe7ef6
--- /dev/null
+++ b/xfce-base/exo/files/exo-0.11.0-env.patch
@@ -0,0 +1,26 @@
+diff --git a/exo-helper/exo-helper.c b/exo-helper/exo-helper.c
+index ce5ef9e..7b4b9c2 100644
+--- a/exo-helper/exo-helper.c
++++ b/exo-helper/exo-helper.c
+@@ -406,7 +406,7 @@ exo_helper_execute (ExoHelper *helper,
+ envp = g_environ_setenv (envp, "DISPLAY", display, TRUE);
+
+ /* try to run the command */
+- succeed = g_spawn_async (NULL, argv, envp, G_SPAWN_DO_NOT_REAP_CHILD | G_SPAWN_SEARCH_PATH, NULL, NULL, &pid, &err);
++ succeed = g_spawn_async (NULL, argv, NULL, G_SPAWN_DO_NOT_REAP_CHILD | G_SPAWN_SEARCH_PATH, NULL, NULL, &pid, &err);
+
+ /* cleanup */
+ g_strfreev (argv);
+diff --git a/exo/exo-execute.c b/exo/exo-execute.c
+index 1fabf57..f6016cf 100644
+--- a/exo/exo-execute.c
++++ b/exo/exo-execute.c
+@@ -150,7 +150,7 @@ exo_execute_preferred_application_on_screen (const gchar *category,
+ envp = g_environ_setenv (envp, "DISPLAY", display, TRUE);
+
+ /* launch the command */
+- success = g_spawn_async (working_directory, argv, envp, 0, NULL, NULL, NULL, error);
++ success = g_spawn_async (working_directory, argv, NULL, 0, NULL, NULL, NULL, error);
+
+ g_free (display);
+ g_strfreev (envp);