summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-05 21:09:53 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-05 21:09:53 +0200
commit40c1832fb0d2b37861ed4dbdc2cd2876a53f90cd (patch)
treed953a2e3f277c34b8fed4a877a7c2d0ca608bfb6 /xfce-base
parentsys-libs/libcxx: Backport libsupc++ build fix to 7.0.0 (diff)
downloadgentoo-40c1832fb0d2b37861ed4dbdc2cd2876a53f90cd.tar.gz
gentoo-40c1832fb0d2b37861ed4dbdc2cd2876a53f90cd.tar.bz2
gentoo-40c1832fb0d2b37861ed4dbdc2cd2876a53f90cd.zip
xfce-base/xfce4-session: Fix relying on implicit dbus header paths
Backport an upstream patch removing unnecessary use of dbus headers. This causes the package to implicitly rely on dbus include paths being added by pkg-config, and causes build failure in the rare case when xfce4-session dependencies do not require dbus. Closes: https://bugs.gentoo.org/667440 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-session/files/xfce4-session-4.13.1-kill-dbus-includes.patch43
-rw-r--r--xfce-base/xfce4-session/xfce4-session-4.13.1.ebuild4
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/xfce4-session/files/xfce4-session-4.13.1-kill-dbus-includes.patch b/xfce-base/xfce4-session/files/xfce4-session-4.13.1-kill-dbus-includes.patch
new file mode 100644
index 000000000000..cc5bb9d653ee
--- /dev/null
+++ b/xfce-base/xfce4-session/files/xfce4-session-4.13.1-kill-dbus-includes.patch
@@ -0,0 +1,43 @@
+From 3bddf152b902d8a1e0f674b792577b2cca635c4b Mon Sep 17 00:00:00 2001
+From: Brandon Bergren <xfce@bdragon.rtk0.net>
+Date: Sun, 26 Aug 2018 10:28:05 -0400
+Subject: [PATCH] fix build failure when dbus is not in the system include path
+ (Bug #14386)
+
+The d-bus direct depenencies were taken out in 91860af3a38080,
+but the #include <dbus/dbus.h> in xfce4-session/xfsm-global.h
+and the #include <dbus/dbus-glib.h> line in xfsm-error.c got left
+in accidentally.
+---
+ xfce4-session/xfsm-error.c | 2 --
+ xfce4-session/xfsm-global.h | 1 -
+ 2 files changed, 3 deletions(-)
+
+diff --git a/xfce4-session/xfsm-error.c b/xfce4-session/xfsm-error.c
+index 2b7f6c04..f0766f5f 100644
+--- a/xfce4-session/xfsm-error.c
++++ b/xfce4-session/xfsm-error.c
+@@ -20,8 +20,6 @@
+ #include <config.h>
+ #endif
+
+-#include <dbus/dbus-glib.h>
+-
+ #include <xfce4-session/xfsm-error.h>
+
+ #define XFSM_DBUS_NAME "org.xfce.SessionManager"
+diff --git a/xfce4-session/xfsm-global.h b/xfce4-session/xfsm-global.h
+index d4587123..610d5bf7 100644
+--- a/xfce4-session/xfsm-global.h
++++ b/xfce4-session/xfsm-global.h
+@@ -27,7 +27,6 @@
+ #include <X11/SM/SMlib.h>
+
+ #include <xfce4-session/xfsm-splash-screen.h>
+-#include <dbus/dbus.h>
+
+ typedef struct _FailsafeClient FailsafeClient;
+ struct _FailsafeClient
+--
+2.19.0
+
diff --git a/xfce-base/xfce4-session/xfce4-session-4.13.1.ebuild b/xfce-base/xfce4-session/xfce4-session-4.13.1.ebuild
index 7819b1d88835..d0df74cf881d 100644
--- a/xfce-base/xfce4-session/xfce4-session-4.13.1.ebuild
+++ b/xfce-base/xfce4-session/xfce4-session-4.13.1.ebuild
@@ -44,6 +44,10 @@ PATCHES=(
# TODO: this patch needs updating for the new version, and finding
# upstream bug.
# "${FILESDIR}"/${PN}-4.12.1-light-locker_support_to_xflock4.patch
+
+ # fix building with no dbus dependency
+ # https://bugs.gentoo.org/667440
+ "${FILESDIR}"/xfce4-session-4.13.1-kill-dbus-includes.patch
)
src_configure() {