summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-21 23:12:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-21 23:14:59 +0100
commit476836c62f2a0f615db65fe6409692e2c1c870eb (patch)
tree1ffde6622fb1568386fd6fc7080d63280f406fe3 /xfce-base
parentdev-libs/cereal: fix CMake option (diff)
downloadgentoo-476836c62f2a0f615db65fe6409692e2c1c870eb.tar.gz
gentoo-476836c62f2a0f615db65fe6409692e2c1c870eb.tar.bz2
gentoo-476836c62f2a0f615db65fe6409692e2c1c870eb.zip
xfce-base/libxfce4util: Bump to 4.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.17.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 8f10e408565c..4e2e4acc87f2 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4util-4.16.0.tar.bz2 508328 BLAKE2B 99578b898389bd90841a7f903f5473b2ff357cf81256efe1019425b48da32401ce238deffefd299987477f4cdfb77e86e415b55049863c30bf16e0e641e08c72 SHA512 dce6992c3da73367461d7464794a9b2a5503666113682e07a86e18b1c5383de2b087809448d5729097571f4fda6b4af5f4f4600848514ab2ab4b3f367ca26f5c
DIST libxfce4util-4.17.1.tar.bz2 527366 BLAKE2B 12de2090c0e2f7bb2bdd19ce63988810978f6d5893f866d65348dedfbb260ec11b518f8375ddc19a0a3502b14743878eb731ece79f31edf94d2bd505ea80d9c5 SHA512 49d11b50bbb0f72637bbdb9abba4e526f34814900dae337ad5e53df4514019a9761a89ef65a39e6ad94d633f7617c8466cb3985c5fae5350c45955d36077a0fc
+DIST libxfce4util-4.17.2.tar.bz2 518831 BLAKE2B 4f1241271edab56063c8e5f3ad6b662a19b08ea06c73eb76e124d9fc8cd9a2b26578517fc6e4b0d5e8c3351877c7b5e077818b916297ac24e273c745cb624eec SHA512 3f079570916c3876373155a3ea15b6326ddadd815efdf7d7abd2ccd9768a96b3191f4e050bb51f2e28bc6b121b7ef9823e7a4caf608398220f527a4df7e29c6f
diff --git a/xfce-base/libxfce4util/libxfce4util-4.17.2.ebuild b/xfce-base/libxfce4util/libxfce4util-4.17.2.ebuild
new file mode 100644
index 000000000000..082ab77a153e
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.17.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}