summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-02 11:38:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-02 12:06:26 +0200
commit70c14496e1403f423b879c7deecafb7a1c50efb0 (patch)
treedb0438fa92e99cf1d06d79536d359c54c6897dc4 /xfce-base
parentdev-python/pypy3: Pass CC to build system (diff)
downloadgentoo-70c14496e1403f423b879c7deecafb7a1c50efb0.tar.gz
gentoo-70c14496e1403f423b879c7deecafb7a1c50efb0.tar.bz2
gentoo-70c14496e1403f423b879c7deecafb7a1c50efb0.zip
xfce-base/thunar: Bump to 4.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.15.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 48f8bb11a7ee..70184270d1e7 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -2,3 +2,4 @@ DIST thunar-1.8.12.tar.bz2 2367685 BLAKE2B 259e7a2c9aeb66673a7b5e6d7147d5257d64b
DIST thunar-1.8.14.tar.bz2 2373742 BLAKE2B 32cdc316defaf781e705ecd9e0550014e1270f09e8eb914f164df4bc557c433fcedbcfb41e200faf317bbab96a20275e4416945050cb10981ee68e0f0cdd357d SHA512 ce6da526e6378ffc90686f6ae25e56109e8af7d0c592345aca3de4603f4c5b3d089255bc313f2a60ee454cc3f0af52106584663c72ecd542a9c92769559c6787
DIST thunar-1.8.15.tar.bz2 2366401 BLAKE2B 2d594ccf4e0eb68fd9f1129b2d737121982ed4275265ea26866c766755f717cfa197abf89ff9d3c07403a71b7feb29ccfabb14e935ec08fab418b173c39fd8f6 SHA512 50020084105daf5d5464cdcd29827fa212b121b0f6a385b6e2820fd120b6880cffafe63f51e737bc33d13f174f83de5c165f2ce155ff6aae74cc1b285cbdc8db
DIST thunar-4.15.0.tar.bz2 2444610 BLAKE2B c07cf9f29efad7f9ce2031b9f5f70f48afe7ced360495a51f7ad201efd41607ba557bc446210db13b11ece41ca104182d006d5fd8071e9fac540094ef48860e3 SHA512 17c78ccd8a97481135ab1c05be4dd666136cc0ab546fb3da52d48e38dbb04a035cdca172afc8b5c9df5cdb8fba4189b84846e96b12a8fa8cab3b3901ef92f4ef
+DIST thunar-4.15.1.tar.bz2 2468765 BLAKE2B 6620c5eef9e8d0afdbb9f38813127cd1cda7085f64951734b96c8f06fb44432a481be8045bea4bf81c28bc292aeabd6cecd1e9b49ae049e3f436f4d78768f662 SHA512 51ba1e6e8078093b1eef3b3440c258ed86e06e54abaeeadb459dde2ba6304c93e291667a2f2c82161e2002e21aaa7c8fe26d8f30ecae8846f30bf0a4569a9cfa
diff --git a/xfce-base/thunar/thunar-4.15.1.ebuild b/xfce-base/thunar/thunar-4.15.1.ebuild
new file mode 100644
index 000000000000..d8a4c532ccf8
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.15.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-0.12:=
+ >=xfce-base/libxfce4ui-4.15.3:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}