summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-04-11 11:46:40 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-04-11 11:46:40 -0700
commit71c886b354fc68906e9600779ed3e2026406cff2 (patch)
tree7158d62d14c2c030fc330bf85eed3a45fede26c4 /xfce-base
parentdev-perl/Cache: 2.110.0 ALLARCHES stable re bug #615134 (diff)
downloadgentoo-71c886b354fc68906e9600779ed3e2026406cff2.tar.gz
gentoo-71c886b354fc68906e9600779ed3e2026406cff2.tar.bz2
gentoo-71c886b354fc68906e9600779ed3e2026406cff2.zip
xfce-base/xfce4-panel: Version bump to 4.12.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/Manifest1
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.12.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/Manifest b/xfce-base/xfce4-panel/Manifest
index 5f0b97536d4f..53391e8a1466 100644
--- a/xfce-base/xfce4-panel/Manifest
+++ b/xfce-base/xfce4-panel/Manifest
@@ -1 +1,2 @@
DIST xfce4-panel-4.12.0.tar.bz2 1107470 SHA256 30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff8261b97b0 SHA512 9b5d0d51ac2c312d54e8daeea95bd861891e652faeee8b4a7dbf4b33507b70bf7b4fbca7cb8f2d3573699ae940a14d5a9a41da24f324db256146d8b7db8519a8 WHIRLPOOL 5468a67b2c4fe1fcf82d3f38a0a0a057f3dac714354f2b2e8ce0c2a8654ac92cf4d0c40b0a0ec00957da2db67db3cec2017673bfc0eeaac69a98e2f92d31c3f1
+DIST xfce4-panel-4.12.1.tar.bz2 1142476 SHA256 93d58b80cca9c9eb58adb281bc75404df7cf6cae89f7f98bb9f38690009aa2e8 SHA512 8bdc2a560a698e7d41429b40cde51ea1bec5aba211b6ee89b46822a38176e27e332efa785d93901d598b17171c739406e7f983372aaa49177db0f868aea985a4 WHIRLPOOL ed0c455c35f00a2cbf8f7a2625ba14e06f6816d5c004110fc849f05050e79aab35ba7eb1c6b6c0709dd7ad1e3e0cac6734cee453b77eceda0584b48d857726d6
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.12.1.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.12.1.ebuild
new file mode 100644
index 000000000000..fbcceb824a1e
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.12.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ >=x11-libs/cairo-1
+ >=x11-libs/gtk+-2.20:2
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/libX11
+ >=x11-libs/libwnck-2.31:1
+ >=xfce-base/exo-0.8
+ >=xfce-base/garcon-0.3
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --enable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS THANKS )
+}