summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-09 22:21:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-09 22:21:16 +0200
commitac35a5f0430cbd084294397ef11178d267e1391f (patch)
tree70eeee5c382e56c984c2fbac6881764707969fdb /xfce-base
parentapp-editors/mousepad: Bump to 0.5.10 (diff)
downloadgentoo-ac35a5f0430cbd084294397ef11178d267e1391f.tar.gz
gentoo-ac35a5f0430cbd084294397ef11178d267e1391f.tar.bz2
gentoo-ac35a5f0430cbd084294397ef11178d267e1391f.zip
xfce-base/thunar: Bump to 4.17.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.17.9.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 21eb027f803a..5aca8ed412ee 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,3 @@
DIST thunar-4.16.11.tar.bz2 2326592 BLAKE2B 0e077f2b4bba613849d3dabaebfa652fd99cc2d1035320016fd4e87597e1af1f6330c2758feead307c6182784de65a358058e2a482f2e287447cdd05d00c8404 SHA512 41b390ce269911e4f0b83c07bf910274cf13afcd293389b156457764a0c771dcb87c03976debe0c4ce06c6a5eeca32fd043cbc3e92d4c7ea8fb00da973b06404
DIST thunar-4.17.8.tar.bz2 2713668 BLAKE2B 96f54c6058dd58e012a69e38db4502a540806e5709f10f414091e6e9a98b2a186cecca337df702978f98fb3d2413acaa3e3d50a695e132b5416391cfd9c0260c SHA512 bae2f1453509c50e8dedd7f7570e95d0b84cf946829b29849c55f90863f29ba8eb7fa06b0aec3a4506368c24c964423d6920707d31cef4091fb700da3b62f19a
+DIST thunar-4.17.9.tar.bz2 2786205 BLAKE2B 2b497e8653fe83581fcec78959dafce3764c98564cfa36bfe26a7cdf2aa3f0b8bf7c41b5e002ca3999931c21856adec74ea2f5f3d863da89bd6e89025f5a83c1 SHA512 029d7e893cbe38d5c968dd9ac6141b52c513bcb7bb1c9a566082e51bd86f22993acf8ba65cba05d341558a06c57aa36e51dbf702044fd3ea0176a88fae158cc2
diff --git a/xfce-base/thunar/thunar-4.17.9.ebuild b/xfce-base/thunar/thunar-4.17.9.ebuild
new file mode 100644
index 000000000000..2f63d8467516
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.17.9.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://www.xfce.org/projects/
+ https://docs.xfce.org/xfce/thunar/start
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+DEPEND="
+ >=dev-libs/glib-2.66
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.6:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}