summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-11 11:15:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-11 11:15:35 +0200
commitd6cf0646a4588a41930808f171885395400324cd (patch)
tree97f0bce25b43436005c0898933fb122a33162c51 /xfce-base
parentwww-servers/apache: create /var/cache/apache2 with tmpfiles (diff)
downloadgentoo-d6cf0646a4588a41930808f171885395400324cd.tar.gz
gentoo-d6cf0646a4588a41930808f171885395400324cd.tar.bz2
gentoo-d6cf0646a4588a41930808f171885395400324cd.zip
xfce-base/garcon: Bump to 4.17.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-4.17.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 1b39242e3d7a..52b76ef5e020 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1,2 +1,3 @@
DIST garcon-0.8.0.tar.bz2 539061 BLAKE2B 8d7b207fdb325d060c3ecfa5e2574961082706c5a4af59cabebad9d3c915228085dc32442521018bfb7da2d3c169445ac270c00c381e666bfda8774329a60cfc SHA512 708c68c31c0d3d89ecdde4790594837af0d065ecb805131fd7db2eb4c433c0523f44d51f2040f7bf9af729537e5f9e89ed06a435fc0c4e6113db00ad78ba8ce0
DIST garcon-4.17.0.tar.bz2 545911 BLAKE2B 0286233a5fc7769955eeb8901a64cd2087d47b28bbb05ae884c6d867e4374191d7dbb0bbc54decf7d4370ae31127d6d5acf63c77d1d18889efa5388bc5d4e5e3 SHA512 6fc88177b8f1b8630fe1f0954151ff60a9957bd7239452317e5e942e70576b996aa59f87e249feb4dfaa256972c3a028323a6fd02826d9b5e4a90df47c7f2361
+DIST garcon-4.17.1.tar.bz2 546754 BLAKE2B b84e502cda113719454353af80a6436f2a4ee1ca132a9d795f49fddeeb7d30abdac3468c6d40b0f23cb68e0584aa7f51c844ca5496a0bf4fa7c60b2d9bbdb3af SHA512 52bd03d7a4b5675b113b14f9acb56a2fb1d60c60a65b06b06376661228bea675e3c8be397b45d7d525fccd21c1bee9802378d11f51ed1f6229a4a5a73b607fe9
diff --git a/xfce-base/garcon/garcon-4.17.1.ebuild b/xfce-base/garcon/garcon-4.17.1.ebuild
new file mode 100644
index 000000000000..c96238763769
--- /dev/null
+++ b/xfce-base/garcon/garcon-4.17.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="https://docs.xfce.org/xfce/garcon/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.7:=[introspection?]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}