summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-11 13:11:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-11 13:11:31 +0200
commitd7072e37b8cb6b20a517b355e00e9675881afaac (patch)
tree081a543f26e062fda2aa5fee1ec20bc2c69c414c /xfce-base
parentllvm.org.eclass: Enable pregen manpages for 14.0.5 (diff)
downloadgentoo-d7072e37b8cb6b20a517b355e00e9675881afaac.tar.gz
gentoo-d7072e37b8cb6b20a517b355e00e9675881afaac.tar.bz2
gentoo-d7072e37b8cb6b20a517b355e00e9675881afaac.zip
xfce-base/exo: Bump to 4.16.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.16.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 975cf4df43fc..b2b06266e21d 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,3 +1,4 @@
DIST exo-4.16.2.tar.bz2 881098 BLAKE2B df1ad499becd22087724abb716d07a50e432ec555d03a3892d0b81745045c334cb3705419e901697e4c3bc10328837b4f5c4055800d1b6c79c9cfc503427643b SHA512 9c1252d78f5bb900254841a79f1c1b952cb60d9d0197e184266c35a86c340140cdff2460fa83f6fabb66380e2b3d7ab8a08719b4f4784d2215dde51410ce33e8
DIST exo-4.16.3.tar.bz2 885516 BLAKE2B 1689821fc8cc72fc848d627d2cccd886223740c2910ed2f42fa70545dfb604eb184d3cfbf6aa93e7723fcc59291e0c33f77e478429e1e4296b2243155e277604 SHA512 0dc4d2da6dd80a4c1b05a5316bb6e7ad02858d3fb49b666d6065bd7b11d7b8aed2732135eee8393185a0c321a242807d97b51f794186ce7a769ec2c9106ba8fd
+DIST exo-4.16.4.tar.bz2 876080 BLAKE2B a29511c0d2e1bbbd861cfd8946d2f2917eb1004bb85621d0bb8bb9b1339f213a14da651e16a6492138cceff8e3e0ec1d1132226ac60a9846426bf6dc2a621ded SHA512 2cf2267a0bd8526dc870cbe48a0d95573c153a990caffabb13365c6e90c155b6d3383ad1282715cb22ce413e704d170bf7fec1af09ad1b0609507a46c4d1233d
DIST exo-4.17.1.tar.bz2 877757 BLAKE2B 152e168568f4ad12e1eb03f7b1971b3369647da0adac57f55d36fc176c36f7c2ccf9125f6bad386843753855b4bbb679a7a6abd80a9375d2212550e0987d4fa4 SHA512 597fee2cc0188159d5278bb5d547f1a4619645684ba3da4046946c5eb38b2a4913731e589caeeb2f8505516bdcbba64bee03291857215e2b4208aa3d2c563988
diff --git a/xfce-base/exo/exo-4.16.4.ebuild b/xfce-base/exo/exo-4.16.4.ebuild
new file mode 100644
index 000000000000..e01d5f2311eb
--- /dev/null
+++ b/xfce-base/exo/exo-4.16.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16.0-allow-cross.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ # needs to be executed after glib-gettextize, bug 829859
+ intltoolize --automake --copy --force || die "intltoolize failed"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}