summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2017-12-11 13:42:02 +0000
committerDenis Dupeyron <calchan@gentoo.org>2017-12-11 13:42:30 +0000
commitba86e631489437739bdb6303d6f37fc91ea4ae8b (patch)
treec03239584c5067c47f89c8361d807f9a94668001 /xfce-extra/thunar-volman
parentapp-eselect/eselect-php: drop unused eselect-php-0.9.4-r2.ebuild. (diff)
downloadgentoo-ba86e631489437739bdb6303d6f37fc91ea4ae8b.tar.gz
gentoo-ba86e631489437739bdb6303d6f37fc91ea4ae8b.tar.bz2
gentoo-ba86e631489437739bdb6303d6f37fc91ea4ae8b.zip
xfce-extra/thunar-volman: remove obsolete xfconf.eclass, migrate to EAPI6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'xfce-extra/thunar-volman')
-rw-r--r--xfce-extra/thunar-volman/thunar-volman-0.8.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/thunar-volman/thunar-volman-0.8.1-r1.ebuild b/xfce-extra/thunar-volman/thunar-volman-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..ec545aa032d7
--- /dev/null
+++ b/xfce-extra/thunar-volman/thunar-volman-0.8.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libnotify"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30
+ virtual/libgudev:=
+ >=x11-libs/gtk+-2.24:2
+ >=xfce-base/exo-0.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/udev
+ >=xfce-base/thunar-1.6[udisks]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}