summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-11 21:16:51 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-11 21:16:51 +0200
commit4c17df3607359eb81f42a0c092e22a3b2aeb8e7a (patch)
tree6a6475fbcdc40d9981f4b38b5f851fdb35c4325c /xfce-extra/xfce4-places-plugin
parentxfce-extra/xfce4-datetime-plugin: Bump to 0.8.0 (diff)
downloadgentoo-4c17df3607359eb81f42a0c092e22a3b2aeb8e7a.tar.gz
gentoo-4c17df3607359eb81f42a0c092e22a3b2aeb8e7a.tar.bz2
gentoo-4c17df3607359eb81f42a0c092e22a3b2aeb8e7a.zip
xfce-extra/xfce4-places-plugin: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-places-plugin')
-rw-r--r--xfce-extra/xfce4-places-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/Manifest b/xfce-extra/xfce4-places-plugin/Manifest
index 63a77343553e..da2907de2ad1 100644
--- a/xfce-extra/xfce4-places-plugin/Manifest
+++ b/xfce-extra/xfce4-places-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-places-plugin-1.7.0.tar.bz2 371395 BLAKE2B fe18391e0cabe06d9d63dfc86a829e35461858b5915d7331053dfabbc9bb689bba0a3cc05b7d7f6dced6e19aa6e32308ba052cca9416bbfb2f050768d3e86f5e SHA512 ae324a29584d7dc6beb4840bec7e4c5802e94c25512f449ab959c588c91f4030d895fe185dad87ab9442611e9fe01f8ccec82e8cb5153cf192d1124156be6bd3
DIST xfce4-places-plugin-1.8.0.tar.bz2 371134 BLAKE2B 5ef5cf79ce565a827520ed281a0be2533df643137d673f12d15393efb2a0ef5db1a18fff3c5e807cdb98d29a8ab4767469fa248cbca85c5a77d9a4e66aff6b59 SHA512 9db3b311881292a9cd380d505be8cd529b51ee92c25e0bbdcbc28dc099369cd7ea078e7c729856d9718967de8f8e2f08db045efb00a4be097d4ebf766da51263
+DIST xfce4-places-plugin-1.8.1.tar.bz2 380906 BLAKE2B 3b5c82fe3fb9fbcc0b9aa79df62da06025f5dd154d4323787d52cbf659351dcc808a4c6e8d4148332eb31a8d292b51d58dba6c81fdf49443b94928a1e82f66f0 SHA512 c0db29050df6ff2862a6ebc6f89d92e39f0c0511f9e719a979b5132935655078a5f5418b8b87bee2fbccaa37f5489d503dc1ae329eb7fd88970dc55b31db3324
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.1.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.1.ebuild
new file mode 100644
index 000000000000..111e64a01f41
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}