summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-30 22:21:49 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-30 22:25:46 +0100
commit51f314b0518f8035e50f0e21c673e1e6f535ef7e (patch)
tree15cc94d63bd7db47346c6b52ad3e855a7e562bcd /xfce-extra/xfce4-screenshooter
parentnet-analyzer/icinga2: remove unused file (diff)
downloadgentoo-51f314b0518f8035e50f0e21c673e1e6f535ef7e.tar.gz
gentoo-51f314b0518f8035e50f0e21c673e1e6f535ef7e.tar.bz2
gentoo-51f314b0518f8035e50f0e21c673e1e6f535ef7e.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-screenshooter')
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest1
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.5.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index 012ab75c0f66..bd9154fb7b6b 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-screenshooter-1.9.3.tar.bz2 502188 BLAKE2B 93b60422eb6cef23b4d1f29fca49370cead8f74c4ee27ea4abf2bb9b4fa006f1dd9e39ccc87c1d915a5e7cc902245caff4b7778b801436a1c25893f46e35f3fb SHA512 ba59fdca3900143a50b3b858986b1152d4574d302d2e041a5287933427a67f64542ca691c130030937344433ea893a1f082086f9c02a9edccaeedbdc0a2a50a2
DIST xfce4-screenshooter-1.9.4.tar.bz2 500260 BLAKE2B e9834e5fab730ee9f22aa18d3e5d68c32afab18a5b621f60c1511b1929fd00f552aa2b9a67f8408c83fced93fa4c28d0a6993081b5dcdd6004e8f61e1d283eff SHA512 9f7240aafe8662cc8a8e105602ba26b31ea212ab4e74f55a4a3c80acf06f0316fe5376430c91a6a0b8e43e85763ca6df6a8af5f64c142c1ca3cce2f8ec3c31f9
+DIST xfce4-screenshooter-1.9.5.tar.bz2 502423 BLAKE2B b71dd5d016ff86ea5b654264dca129fd1b9316a0d0f2926a40556448c11a51992e4921c3ff9da952ac5e2962cf5baa18df8a110127cb68e89ee1b1cb2252bb7a SHA512 e5797a6defa4df94c552e8ff39b21f4203b6795669e8145ea5ef609fc7b29bcfa846b19b253b39b12ab0e6c130c7f9e67dd5aa628cefe9b063fb9f74dd2c3ee1
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.5.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.5.ebuild
new file mode 100644
index 000000000000..745c13b46468
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}