summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-11-20 23:35:39 +0800
committerJason Zaman <perfinion@gentoo.org>2016-11-21 00:18:57 +0800
commitf48e12f670faaa0d036b0247b042de5783edb2fc (patch)
treee380da397daadf9f9d8bd3dea30836adaa3a66a4 /xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.0.ebuild
parentxfce-extra/xfce4-smartbookmark-plugin: bump version and EAPI6 (diff)
downloadgentoo-f48e12f670faaa0d036b0247b042de5783edb2fc.tar.gz
gentoo-f48e12f670faaa0d036b0247b042de5783edb2fc.tar.bz2
gentoo-f48e12f670faaa0d036b0247b042de5783edb2fc.zip
xfce-extra/xfce4-systemload-plugin: bump version and EAPI6
Package-Manager: portage-2.3.0
Diffstat (limited to 'xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.0.ebuild')
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.0.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.0.ebuild
new file mode 100644
index 000000000000..18169f827cd2
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="System load plug-in for Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-systemload-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="upower"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf $(use_enable upower)
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}