summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-21 04:16:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-21 04:23:35 +0200
commit0c06221cd11b4c41245dff941e0d4e0f5af56c50 (patch)
treebce77dce6b2dafd166f5536ae5c77d5239dbe34b /xfce-extra
parentxfce-base/xfce4-appfinder: Bump to 4.15.1 (diff)
downloadgentoo-0c06221cd11b4c41245dff941e0d4e0f5af56c50.tar.gz
gentoo-0c06221cd11b4c41245dff941e0d4e0f5af56c50.tar.bz2
gentoo-0c06221cd11b4c41245dff941e0d4e0f5af56c50.zip
xfce-extra/thunar-volman: Bump to 4.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-volman/Manifest1
-rw-r--r--xfce-extra/thunar-volman/thunar-volman-4.15.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/thunar-volman/Manifest b/xfce-extra/thunar-volman/Manifest
index 2f97c7c68293..bc02be3ed11d 100644
--- a/xfce-extra/thunar-volman/Manifest
+++ b/xfce-extra/thunar-volman/Manifest
@@ -1 +1,2 @@
DIST thunar-volman-0.9.5.tar.bz2 501846 BLAKE2B e64a1593551cb542461be54e7e0624a9e3a3f0db43df166f0922f79e031a0f85da3eb00289a8d30c427c5f6500a3e12b065a7fdf3f34e24d6e88d27be048669a SHA512 843ff1f55b68e6f584da29c2c6c91ed045c4e9ee05cb573db6a0192553cf05faefb4227359bd6ef306c2bbb94e2fe5357c07f70a0d170b35c48d3e9ebac7a9b9
+DIST thunar-volman-4.15.0.tar.bz2 508430 BLAKE2B cffad4035dc203e546bb35e257012890303b8be7efcfa33e5f4178532b3163b1f0d3a497e877018c282e9a23644a6de18fff8e6a199b267027552cfb77673eeb SHA512 e7893e4d256080c999b4a04921dfa21ed7d52c1879c63a3d53e9baf482c021534debb22edd2f5cada34c1be045f2c78725fbecfca2dafe8e17bf2557d86b2496
diff --git a/xfce-extra/thunar-volman/thunar-volman-4.15.0.ebuild b/xfce-extra/thunar-volman/thunar-volman-4.15.0.ebuild
new file mode 100644
index 000000000000..2290a1f6a0fd
--- /dev/null
+++ b/xfce-extra/thunar-volman/thunar-volman-4.15.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+# CC for tvm-burn-cd.svg
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libnotify"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30
+ dev-libs/libgudev:=
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/udev
+ >=xfce-base/thunar-1.6[udisks]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}