summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-23 13:03:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-23 13:06:19 +0100
commit13e45fc64d54adca3d356eb27677db0476f10f6d (patch)
treeed1b09c63a21bad9859ee1f545617c75570e755d /xfce-extra
parentsys-auth/rtkit: remove old (diff)
downloadgentoo-13e45fc64d54adca3d356eb27677db0476f10f6d.tar.gz
gentoo-13e45fc64d54adca3d356eb27677db0476f10f6d.tar.bz2
gentoo-13e45fc64d54adca3d356eb27677db0476f10f6d.zip
xfce-extra/xfce4-battery-plugin: Bump to 1.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index a5d4b7d0cbbf..6f562c1a2e93 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-battery-plugin-1.1.3.tar.bz2 431118 BLAKE2B 305255b4ea0f232f5dae29b47c4ec66b26a5848783d6aa6b3379b98fe9312b302cde8302aa3d2c8bd945b3b160cdf5b6e612f452f5595f61ddaf5659342e3480 SHA512 a591fb37855efbd54d18ae97e320fa4521da611c8ea107813bfd66fa570e8c84576fcf779c7b676ee9918709912de728b0fed490e64d3d2ad403baf719db4520
+DIST xfce4-battery-plugin-1.1.4.tar.bz2 458485 BLAKE2B 5af18d0f8944afdc6c93852220cd87020d7ea18ce27e224def5ed71f3d9490e2e30982bbff322a76feb3d6464888a8cd64e40c9938484256432537ea1a150009 SHA512 6a59630800a79d2c62434c1c50f5d891ae9ebae48037ea0859d6edd66c856a76e6f11c6e8866ca3c94ae1e5b57bdba4e9fadd4bc92c7fcef278cd2f7b82203f2
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.4.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.4.ebuild
new file mode 100644
index 000000000000..495bed51cc92
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ >=x11-libs/gtk+-3.16:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}