summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-01-09 15:07:09 +0100
committerMichał Górny <mgorny@gentoo.org>2019-01-09 15:11:10 +0100
commit2a0c0022520d6d50971faa86aca3834420ee25f3 (patch)
tree3354b5fedeb4be899463da718385e1239a13e757 /xfce-extra
parentsys-apps/sandbox: Bump to 2.15 (diff)
downloadgentoo-2a0c0022520d6d50971faa86aca3834420ee25f3.tar.gz
gentoo-2a0c0022520d6d50971faa86aca3834420ee25f3.tar.bz2
gentoo-2a0c0022520d6d50971faa86aca3834420ee25f3.zip
xfce-extra/xfce4-alsa-plugin: Bump to 0.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-alsa-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-alsa-plugin/Manifest b/xfce-extra/xfce4-alsa-plugin/Manifest
index cf924471b304..d7a7662e274b 100644
--- a/xfce-extra/xfce4-alsa-plugin/Manifest
+++ b/xfce-extra/xfce4-alsa-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-alsa-plugin-0.1.1.tar.gz 126701 BLAKE2B a117a737023f0d4ef9473030f9a3e313a53687f4a4b049147be6a63320e346db3d0d2cafef55ff13546fdacab70f849acd1006f39b8606fc8a51323562214c08 SHA512 05273467944a08dd87455fcf20da0292899ace7254afcd2eb141c8d3f10996ad8ee08c6e61abb0178f65d52b066b0804e05a579d0a7f7e65b46fe5c4fd744fd7
+DIST xfce4-alsa-plugin-0.1.2.tar.gz 26775 BLAKE2B 5187d0ce92c233742531b29d82c04ce554c244eb3a1dcc0d727c82bffd289cb839c95da047e8e900f01bb7e30adc80869cd6468ce7c372eed04d837467f4e8cf SHA512 aee7778325fcf37d124d60c072f9c6038ee81c56b1e0f00a36e26f1828e81760687ef8917ec715731b6b20c04bb8db9f7c8db67618de5baab42dfba7c77143c8
diff --git a/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.2.ebuild b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.2.ebuild
new file mode 100644
index 000000000000..c59e2c8fbfc8
--- /dev/null
+++ b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vala meson
+
+DESCRIPTION="Simple ALSA volume control for xfce4-panel"
+HOMEPAGE="https://github.com/equeim/xfce4-alsa-plugin"
+SRC_URI="https://github.com/equeim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/alsa-lib
+ >=xfce-base/xfce4-panel-4.13
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+"
+
+src_prepare() {
+ vala_src_prepare
+ eapply_user
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgtk3=true
+ )
+ meson_src_configure
+}