summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-02-03 08:29:22 +0100
committerMichał Górny <mgorny@gentoo.org>2019-02-03 08:29:52 +0100
commita8c10df5bb6cdd48089836303a44553b19827da1 (patch)
treefdd122cbc855121ca87d1048de8ab0f2dd1ecdf1 /xfce-extra
parentapp-doc/php-docs: Refresh to current docs (diff)
downloadgentoo-a8c10df5bb6cdd48089836303a44553b19827da1.tar.gz
gentoo-a8c10df5bb6cdd48089836303a44553b19827da1.tar.bz2
gentoo-a8c10df5bb6cdd48089836303a44553b19827da1.zip
xfce-extra/xfce4-alsa-plugin: Bump to 0.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-alsa-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-alsa-plugin/Manifest b/xfce-extra/xfce4-alsa-plugin/Manifest
index cb7e37b09803..e6916df65962 100644
--- a/xfce-extra/xfce4-alsa-plugin/Manifest
+++ b/xfce-extra/xfce4-alsa-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-alsa-plugin-0.1.1.tar.gz 126701 BLAKE2B a117a737023f0d4ef9473030f9a3e313a53687f4a4b049147be6a63320e346db3d0d2cafef55ff13546fdacab70f849acd1006f39b8606fc8a51323562214c08 SHA512 05273467944a08dd87455fcf20da0292899ace7254afcd2eb141c8d3f10996ad8ee08c6e61abb0178f65d52b066b0804e05a579d0a7f7e65b46fe5c4fd744fd7
+DIST xfce4-alsa-plugin-0.2.0.tar.gz 29283 BLAKE2B 42e93d0968e5275ae5c542b85907e45515eb5886f06675c3e25125796d6ae851540d377e4617c89903b3c8349b2ccdb5b49563f127b82ca7f249514819181c97 SHA512 1d4409aac80d2d0fd3022e8467f77b06df7d6e4bd31e69197caa89c2bf3c4347830054b550d0faf530eaafe05835192c915da36b987847687518e71997620e75
DIST xfce4-alsa-plugin-10159129e14a59d14b5761441aaaf7c2f41a3673.tar.gz 28842 BLAKE2B 4202a077fb2f1030c170dc6e0212aa6dfd68981566494bba2aafe1d0e3fd95847ac67bec590ec193cc0d302b763dab9b512bbc656c4ab535d80fc200e2390215 SHA512 707522eed839ef8af0b5d090670502208851176b1accf885b98d2c2a0a22d7285bf4ce18d390be24034e89cb555745fc58213bc9c61150451046efce68eb28af
diff --git a/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.2.0.ebuild b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.2.0.ebuild
new file mode 100644
index 000000000000..c59e2c8fbfc8
--- /dev/null
+++ b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vala meson
+
+DESCRIPTION="Simple ALSA volume control for xfce4-panel"
+HOMEPAGE="https://github.com/equeim/xfce4-alsa-plugin"
+SRC_URI="https://github.com/equeim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/alsa-lib
+ >=xfce-base/xfce4-panel-4.13
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+"
+
+src_prepare() {
+ vala_src_prepare
+ eapply_user
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgtk3=true
+ )
+ meson_src_configure
+}