summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-apps/wf-recorder/wf-recorder-0.2.1-r1.ebuild (renamed from gui-apps/wf-recorder/wf-recorder-0.2.1.ebuild)25
1 files changed, 18 insertions, 7 deletions
diff --git a/gui-apps/wf-recorder/wf-recorder-0.2.1.ebuild b/gui-apps/wf-recorder/wf-recorder-0.2.1-r1.ebuild
index cbae5bbd6bda..6bc50719fea0 100644
--- a/gui-apps/wf-recorder/wf-recorder-0.2.1.ebuild
+++ b/gui-apps/wf-recorder/wf-recorder-0.2.1-r1.ebuild
@@ -7,20 +7,31 @@ inherit meson
DESCRIPTION="Screen recorder for wlroots-based compositors"
HOMEPAGE="https://github.com/ammen99/wf-recorder"
-SRC_URI="https://github.com/ammen99/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
+else
+ SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE="+man opencl"
-DEPEND="dev-libs/wayland
- dev-libs/wayland-protocols
+DEPEND="
+ dev-libs/wayland
media-sound/pulseaudio
- media-video/ffmpeg
- opencl? ( virtual/opencl )"
+ media-video/ffmpeg[opencl?,pulseaudio,x264]
+ opencl? ( virtual/opencl )
+"
RDEPEND="${DEPEND}"
-BDEPEND="man? ( app-text/scdoc )"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+ man? ( >=app-text/scdoc-1.9.3 )
+"
src_configure() {
local emesonargs=(