summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/easyprocess/easyprocess-0.3-r1.ebuild27
-rw-r--r--dev-python/easyprocess/metadata.xml1
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/easyprocess/easyprocess-0.3-r1.ebuild b/dev-python/easyprocess/easyprocess-0.3-r1.ebuild
new file mode 100644
index 000000000000..20905b3cd3e5
--- /dev/null
+++ b/dev-python/easyprocess/easyprocess-0.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use Python subprocess interface"
+HOMEPAGE="https://github.com/ponty/EasyProcess"
+SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+)"
+
+S="${WORKDIR}/EasyProcess-${PV}"
+
+distutils_enable_tests pytest
diff --git a/dev-python/easyprocess/metadata.xml b/dev-python/easyprocess/metadata.xml
index 1e8b380c0d75..ec678a81e4dd 100644
--- a/dev-python/easyprocess/metadata.xml
+++ b/dev-python/easyprocess/metadata.xml
@@ -9,6 +9,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">EasyProcess</remote-id>
</upstream>