summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/dosbox/dosbox-0.74.3.ebuild4
-rw-r--r--games-emulation/dosbox/dosbox-0.75_pre4302.ebuild4
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild4
-rw-r--r--games-emulation/dosbox/files/dosbox-0.74-ncurses.patch72
4 files changed, 84 insertions, 0 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74.3.ebuild b/games-emulation/dosbox/dosbox-0.74.3.ebuild
index 167f646d3605..418766f8d96c 100644
--- a/games-emulation/dosbox/dosbox-0.74.3.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74.3.ebuild
@@ -45,6 +45,10 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.74-ncurses.patch
+)
+
src_prepare() {
default
eautoreconf
diff --git a/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild b/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild
index ebcdda7b5225..4a25d8ebdb4c 100644
--- a/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild
+++ b/games-emulation/dosbox/dosbox-0.75_pre4302.ebuild
@@ -49,6 +49,10 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.74-ncurses.patch
+)
+
src_prepare() {
use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff
default
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index d6c941250515..3292eebd77d5 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -49,6 +49,10 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.74-ncurses.patch
+)
+
src_prepare() {
use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff
default
diff --git a/games-emulation/dosbox/files/dosbox-0.74-ncurses.patch b/games-emulation/dosbox/files/dosbox-0.74-ncurses.patch
new file mode 100644
index 000000000000..dd7016f8c926
--- /dev/null
+++ b/games-emulation/dosbox/files/dosbox-0.74-ncurses.patch
@@ -0,0 +1,72 @@
+https://sourceforge.net/p/dosbox/patches/286/
+
+--- a/configure.ac 2019-11-12 17:55:51.000000000 +0000
++++ b/configure.ac 2020-01-02 21:26:27.551856431 +0000
+@@ -235,36 +235,38 @@
+ #Features to enable/disable
+ AH_TEMPLATE(C_DEBUG,[Define to 1 to enable internal debugger, requires libcurses])
+ AH_TEMPLATE(C_HEAVY_DEBUG,[Define to 1 to enable heavy debugging, also have to enable C_DEBUG])
+-AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),[
+- AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
+- AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
+- AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
+- AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),,enable_debug=no)
++AC_MSG_CHECKING(whether debug will be enabled)
++
++if test x$enable_debug = xno; then
++ AC_MSG_RESULT(no)
++else
++ AC_MSG_RESULT(yes)
+
+- if test x$enable_debug = xno; then
+- AC_MSG_RESULT([Debugger not enabled])
+- elif test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lncurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lpdcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- else
+- AC_MSG_ERROR([Can't find curses, which is required for debug mode])
+- fi
+-],)
++ PKG_CHECK_MODULES(NCURSES, ncurses, [
++ LIBS="$LIBS $NCURSES_LIBS"; CFLAGS="$CFLAGS $NCURSES_CFLAGS"
++ ], [
++ AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
++ AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
++ AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
++ AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++
++ if test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lncurses"
++ elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lcurses"
++ elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lpdcurses"
++ else
++ AC_MSG_ERROR([Can't find curses, which is required for debug mode])
++ fi
++ ])
++
++ AC_DEFINE(C_DEBUG,1)
++ if test x$enable_debug = xheavy; then
++ AC_DEFINE(C_HEAVY_DEBUG,1)
++ fi
++fi
+
+ AH_TEMPLATE(C_CORE_INLINE,[Define to 1 to use inlined memory functions in cpu core])
+ AC_ARG_ENABLE(core-inline,AC_HELP_STRING([--disable-core-inline],[Disable inlined memory handling in CPU Core]),,enable_core_inline=yes)