summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
index 62d2aabe95ee..fa9bae778568 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
@@ -26,6 +26,16 @@ pkg_pretend() {
use openmp && tc-check-openmp
}
+src_compile() {
+ default
+ if use custom-tune; then
+ # One "emake" was needed to build the library. Now we can find
+ # the best set of parameters, and then run "emake" one more time
+ # to rebuild the library with the custom parameters. See the
+ # project's README or INSTALL-ecm
+ emake ecm-params && emake
+ fi
+}
src_configure() {
econf \
--enable-shared \