summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/six/six-1.10.0.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 6161e0ad2ca7..ffbb168d3c24 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,9 +26,23 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
+# Run twice.
+# pkg_pretend to catch as early as possible, but be forgiving if
+# python impl is not installed allready.
+# pkg_setup to catch them all
pkg_pretend() {
six_dir_check() {
local dir="${ROOT}"/$(python_get_sitedir)/six
+ type -p "${PYTHON}" > /dev/null || return 0
+ [[ -d "${dir}" ]] \
+ && die "${PN} doesn't work if ${dir} is a directory #546730"
+ }
+ python_foreach_impl six_dir_check
+}
+
+pkg_setup() {
+ six_dir_check() {
+ local dir="${ROOT}"/$(python_get_sitedir)/six
[[ -d "${dir}" ]] \
&& die "${PN} doesn't work if ${dir} is a directory #546730"
}