summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/hsopenssl/hsopenssl-0.11.1.1-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-haskell/hsopenssl/hsopenssl-0.11.1.1-r1.ebuild b/dev-haskell/hsopenssl/hsopenssl-0.11.1.1-r1.ebuild
index a0f634a9e852..78c1285de10f 100644
--- a/dev-haskell/hsopenssl/hsopenssl-0.11.1.1-r1.ebuild
+++ b/dev-haskell/hsopenssl/hsopenssl-0.11.1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -38,6 +38,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ cabal_chdeps \
+ 'time >= 1.1.1 && < 1.6' 'time >= 1.1.1'
+}
+
src_configure() {
local fbn_flag=$(cabal_flag fast-bignum fast-bignum)