summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/bitcoind/bitcoind-0.16.3.ebuild1
-rw-r--r--net-p2p/bitcoind/bitcoind-0.17.1.ebuild1
-rw-r--r--net-p2p/bitcoind/bitcoind-0.18.0.ebuild1
-rw-r--r--net-p2p/bitcoind/files/bitcoind-0.16.3-missing-include.patch10
4 files changed, 13 insertions, 0 deletions
diff --git a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
index 9147db4d3e08..86589b99be5e 100644
--- a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
@@ -71,6 +71,7 @@ src_prepare() {
local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+ eapply "${FILESDIR}"/${PN}-0.16.3-missing-include.patch
eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
if use knots; then
diff --git a/net-p2p/bitcoind/bitcoind-0.17.1.ebuild b/net-p2p/bitcoind/bitcoind-0.17.1.ebuild
index 2f1df22dec83..f8e1efe4331a 100644
--- a/net-p2p/bitcoind/bitcoind-0.17.1.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.17.1.ebuild
@@ -71,6 +71,7 @@ src_prepare() {
local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+ eapply "${FILESDIR}"/${PN}-0.16.3-missing-include.patch
eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
if use knots; then
diff --git a/net-p2p/bitcoind/bitcoind-0.18.0.ebuild b/net-p2p/bitcoind/bitcoind-0.18.0.ebuild
index d758ec041969..6b144706f370 100644
--- a/net-p2p/bitcoind/bitcoind-0.18.0.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.18.0.ebuild
@@ -75,6 +75,7 @@ src_prepare() {
local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+ eapply "${FILESDIR}"/${PN}-0.16.3-missing-include.patch
eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
if use knots; then
diff --git a/net-p2p/bitcoind/files/bitcoind-0.16.3-missing-include.patch b/net-p2p/bitcoind/files/bitcoind-0.16.3-missing-include.patch
new file mode 100644
index 000000000000..f413c323b92d
--- /dev/null
+++ b/net-p2p/bitcoind/files/bitcoind-0.16.3-missing-include.patch
@@ -0,0 +1,10 @@
+--- a/src/httpserver.cpp
++++ b/src/httpserver.cpp
+@@ -13,6 +13,7 @@
+ #include <sync.h>
+ #include <ui_interface.h>
+
++#include <deque>
+ #include <memory>
+ #include <stdio.h>
+ #include <stdlib.h>