summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/libreoffice-bin/libreoffice-bin-6.2.5.2.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/app-office/libreoffice-bin/libreoffice-bin-6.2.5.2.ebuild b/app-office/libreoffice-bin/libreoffice-bin-6.2.5.2.ebuild
index 964f77080a51..8317169b37ec 100644
--- a/app-office/libreoffice-bin/libreoffice-bin-6.2.5.2.ebuild
+++ b/app-office/libreoffice-bin/libreoffice-bin-6.2.5.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
BASE_PACKAGENAME="bin"
BASE_AMD64_URI="https://tamiko.kyomu.43-1.org/distfiles/amd64-${BASE_PACKAGENAME}-"
@@ -10,7 +10,7 @@ BASE_X86_URI="https://tamiko.kyomu.43-1.org/distfiles/x86-${BASE_PACKAGENAME}-"
PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="threads,xml"
-inherit gnome2-utils java-pkg-opt-2 python-single-r1 pax-utils prefix versionator xdg-utils
+inherit java-pkg-opt-2 python-single-r1 prefix xdg-utils
DESCRIPTION="A full office productivity suite. Binary package"
HOMEPAGE="https://www.libreoffice.org"
@@ -157,8 +157,8 @@ COMMON_DEPEND="
kde? (
dev-qt/qtcore:5
dev-qt/qtgui:5
- dev-qt/qtx11extras:5
dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
kde-frameworks/kconfig:5
kde-frameworks/kcoreaddons:5
kde-frameworks/ki18n:5
@@ -213,7 +213,7 @@ src_unpack() {
use gnome && patchname="-gnome"
use java && patchname="${patchname}-java"
- if [ -n "${patchname}" ]; then
+ if [[ -n "${patchname}" ]]; then
einfo "Patching distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar using ${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3"
xdelta3 -d -s "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3" "${WORKDIR}/tmpdist.tar" || die
mv "${WORKDIR}/tmpdist.tar" "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
@@ -241,24 +241,17 @@ src_install() {
insinto /etc/revdep-rebuild && doins "${T}/50-${PN}"
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
- pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
- pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
-
use java || \
ewarn 'If you plan to use lbase application you should enable java or you will get various crashes.'
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}