summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-PEAR/Manifest1
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.10.3.ebuild150
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild108
3 files changed, 0 insertions, 259 deletions
diff --git a/dev-php/PEAR-PEAR/Manifest b/dev-php/PEAR-PEAR/Manifest
index a5823de4bb74..99ffb461a13e 100644
--- a/dev-php/PEAR-PEAR/Manifest
+++ b/dev-php/PEAR-PEAR/Manifest
@@ -1,3 +1,2 @@
DIST PEAR-1.10.1.tgz 291167 SHA256 7eca0d8e4f6391d66d92abc4faebd5a9346e739b92573e20392db9e878a8d59f SHA512 df5f09a92d211a09dae147af474399171aed46e0536c091468b73b43ba4acdbdbf7b5cbdd17ef48b7d36d7b9dd23187dc6c75733731c267768d49c89698b0ef2 WHIRLPOOL ef067937d805a1e5c082c5945ffcbffd005757326f72572563154f2b5c573713050cc002af7727ebe053b3956fa1113c29bbbad6e74d8fb110704b07b7291929
DIST PEAR-1.10.3.tgz 291095 SHA256 c882979c48640b0b1a71cf2290dad3b3bbef1c33e4f1ec9af36a710e88e7921a SHA512 1ad531a6e0ac30719b05e58f0758393bc6cdb0e89b4f99f843e7318a40ef18e74767e8ed63346b0ece9d6e8e71c8ebe15b08eaeb6f0c4f3169814bb4bb524332 WHIRLPOOL 987d875a76ccbf26ea3fce0ca1b11d0885bcd98c73c1bdd43ce41f5f0cec4504f769aaa2b1bca3e501763ab21c3d6980a2eb02d26bfdfbd6f9a28f938ebbd4ea
-DIST PEAR-1.9.4.tgz 296332 SHA256 80c329264a0363c6222b2f750e1646015161c9787bb4041f5ab41d95160bb93c SHA512 f4c8c6f24039940254cf774e51087a12e6b17f7cbd7308c814f8b43f1342ae68db6b2d94626a4d7ed05e8b537816da08459e2939689f15aef725504683657f47 WHIRLPOOL a640fa5dff5eda2801698094b3d99c7c63d9028727f323634dc6c17942d4cbf4fe76ddd35b89a11a8187de068201b875642bf90ea705544801d4ffaac3325828
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.10.3.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.10.3.ebuild
deleted file mode 100644
index 6e5ca9b1dcb8..000000000000
--- a/dev-php/PEAR-PEAR/PEAR-PEAR-1.10.3.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PEAR Base System"
-HOMEPAGE="http://pear.php.net/package/${MY_PN}"
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="dev-lang/php:*[cli,xml,zlib]
- >=dev-php/PEAR-Archive_Tar-1.4.0
- >=dev-php/PEAR-Console_Getopt-1.4.1
- >=dev-php/PEAR-Structures_Graph-1.1.0
- >=dev-php/PEAR-XML_Util-1.3.0"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/gentoo-libtool-mismatch-fix-v2.patch" )
-
-pkg_setup() {
- [[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="${EPREFIX}/var/cache/pear"
- [[ -z "${PEAR_DOWNLOADDIR}" ]] && PEAR_DOWNLOADDIR="${EPREFIX}/var/tmp/pear"
- [[ -z "${PEAR_TEMPDIR}" ]] && PEAR_TEMPDIR="${EPREFIX}/tmp"
-
- elog
- elog "cache_dir is set to: ${PEAR_CACHEDIR}"
- elog "download_dir is set to: ${PEAR_DOWNLOADDIR}"
- elog "temp_dir is set to: ${PEAR_TEMPDIR}"
- elog
- elog "If you want to change the above values, you need to set"
- elog "PEAR_CACHEDIR, PEAR_DOWNLOADDIR and PEAR_TEMPDIR variable(s)"
- elog "accordingly in /etc/portage/make.conf and re-emerge ${PN}."
- elog
-}
-
-src_install() {
- insinto /usr/share/php
- doins -r PEAR/
- doins -r OS/
- doins PEAR.php System.php
- doins scripts/pearcmd.php
- doins scripts/peclcmd.php
-
- newbin scripts/pear.sh pear
- newbin scripts/peardev.sh peardev
- newbin scripts/pecl.sh pecl
-
- # adjust some scripts for current version
- for i in pearcmd.php peclcmd.php ; do
- sed "s:@pear_version@:${PEAR}:g" -i "${D}/usr/share/php/${i}" \
- || die "failed to sed pear_version"
- done
-
- for i in pear peardev pecl ; do
- sed "s:@bin_dir@:${EPREFIX}/usr/bin:g" -i "${D}/usr/bin/${i}" \
- || die "failed to sed @bin_dir@ in ${i}"
- sed "s:@php_dir@:${EPREFIX}/usr/share/php:g" -i "${D}/usr/bin/${i}" \
- || die "failed to sed @php_dir@ in ${i}"
- done
-
- sed "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" \
- -i "${D}/usr/bin/pear" \
- || die "failed to set PHP ini values in pear executable"
-
- sed "s:@package_version@:${PEAR}:g" \
- -i "${D}/usr/share/php/PEAR/Command/Package.php" \
- || die "failed to sed @package_version@"
-
- sed "s:@PEAR-VER@:${PEAR}:g" \
- -i "${D}/usr/share/php/PEAR/Dependency2.php" \
- || die "failed to sed @PEAR-VER@ in Dependency2.php"
-
- sed "s:@PEAR-VER@:${PEAR}:g" \
- -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v1.php" \
- || die "failed to sed @PEAR-VER@ in v1.php"
-
- sed "s:@PEAR-VER@:${PEAR}:g" \
- -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v2.php" \
- || die "failed to sed @PEAR-VER@ in v2.php"
-
- # finalize install
- insinto /etc
- newins "${FILESDIR}"/pear.conf-r2 pear.conf
-
- sed "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed PHPCLILEN in pear.conf"
-
- sed "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed CACHEDIRLEN in pear.conf"
-
- sed "s|s:DOWNLOADDIRLEN:\"DOWNLOADDIR\"|s:${#PEAR_DOWNLOADDIR}:\"${PEAR_DOWNLOADDIR}\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed DOWNLOADDIRLEN in pear.conf"
-
- sed "s|s:TEMPDIRLEN:\"TEMPDIR\"|s:${#PEAR_TEMPDIR}:\"${PEAR_TEMPDIR}\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed TEMPDIRLEN in pear.conf"
-
- # Change the paths for eprefix!
- sed "s|s:19:\"/usr/share/php/docs\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/docs\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed the docs path (prefix) in pear.conf"
-
- sed "s|s:19:\"/usr/share/php/data\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/data\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed the data path (prefix) in pear.conf"
-
- sed "s|s:20:\"/usr/share/php/tests\"|s:$(( ${#EPREFIX}+20 )):\"${EPREFIX}/usr/share/php/tests\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed the tests path (prefix) in pear.conf"
-
- sed "s|s:14:\"/usr/share/php\"|s:$(( ${#EPREFIX}+14 )):\"${EPREFIX}/usr/share/php\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed the PHP include path (prefix) in pear.conf"
-
- sed "s|s:8:\"/usr/bin\"|s:$(( ${#EPREFIX}+8 )):\"${EPREFIX}/usr/bin\"|g" \
- -i "${D}/etc/pear.conf" \
- || die "failed to sed the bin path (prefix) in pear.conf"
-
- [[ "${PEAR_TEMPDIR}" != "/tmp" ]] && keepdir "${PEAR_TEMPDIR#${EPREFIX}}"
- keepdir "${PEAR_CACHEDIR#${EPREFIX}}"
- diropts -m1777
- keepdir "${PEAR_DOWNLOADDIR#${EPREFIX}}"
-}
-
-pkg_postinst() {
- pear clear-cache || die "failed to clear PEAR cache"
-
- # Update PEAR/PECL channels as needed, add new ones to the list if needed
- elog "Updating PEAR/PECL channels"
- local pearchans="pear.php.net pecl.php.net pear.phing.info "
- pearchans+="pear.symfony-project.com"
-
- for chan in ${pearchans} ; do
- # The first command may fail if, for example, the channels have
- # already been initialized.
- pear channel-discover ${chan}
- pear channel-update ${chan} || die "failed to update channels: ${chan}"
- done
-}
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild
deleted file mode 100644
index 1314934b24d5..000000000000
--- a/dev-php/PEAR-PEAR/PEAR-PEAR-1.9.4.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils
-
-PEAR="${PV}"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-
-DESCRIPTION="PEAR Base System"
-HOMEPAGE="http://pear.php.net/package/PEAR"
-SRC_URI="http://pear.php.net/get/PEAR-${PEAR}.tgz"
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
- dev-lang/php[cli,xml,zlib]"
-
-RDEPEND="${DEPEND}"
-
-PDEPEND="dev-php/pear"
-
-S="${WORKDIR}"
-
-pkg_setup() {
- [[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="${EPREFIX}/var/cache/pear"
- [[ -z "${PEAR_DOWNLOADDIR}" ]] && PEAR_DOWNLOADDIR="${EPREFIX}/var/tmp/pear"
- [[ -z "${PEAR_TEMPDIR}" ]] && PEAR_TEMPDIR="${EPREFIX}/tmp"
-
- elog
- elog "cache_dir is set to: ${PEAR_CACHEDIR}"
- elog "download_dir is set to: ${PEAR_DOWNLOADDIR}"
- elog "temp_dir is set to: ${PEAR_TEMPDIR}"
- elog
- elog "If you want to change the above values, you need to set"
- elog "PEAR_CACHEDIR, PEAR_DOWNLOADDIR and PEAR_TEMPDIR variable(s)"
- elog "accordingly in /etc/portage/make.conf and re-emerge ${PN}."
- elog
-}
-
-src_prepare() {
- cd PEAR-${PV}
- epatch "${FILESDIR}/gentoo-libtool-mismatch-fix.patch"
-
-}
-
-src_install() {
- # Prevent SNMP related sandbox violoation.
- addpredict /usr/share/snmp/mibs/.index
- addpredict /var/lib/net-snmp/
-
- # install PEAR package
- cd "${S}"/PEAR-${PEAR}
-
- insinto /usr/share/php
- doins -r PEAR/
- doins -r OS/
- doins PEAR.php PEAR5.php System.php
- doins scripts/pearcmd.php
- doins scripts/peclcmd.php
-
- newbin scripts/pear.sh pear
- newbin scripts/peardev.sh peardev
- newbin scripts/pecl.sh pecl
-
- # adjust some scripts for current version
- for i in pearcmd.php peclcmd.php ; do
- sed "s:@pear_version@:${PEAR}:g" -i "${D}/usr/share/php/${i}"
- done
-
- for i in pear peardev pecl ; do
- sed "s:@bin_dir@:${EPREFIX}/usr/bin:g" -i "${D}/usr/bin/${i}"
- sed "s:@php_dir@:${EPREFIX}/usr/share/php:g" -i "${D}/usr/bin/${i}"
- done
- sed "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" -i "${D}/usr/bin/pear"
-
- sed "s:@package_version@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/Command/Package.php"
- sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/Dependency2.php"
- sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v1.php"
- sed "s:@PEAR-VER@:${PEAR}:g" -i "${D}/usr/share/php/PEAR/PackageFile/Parser/v2.php"
-
- # finalize install
- insinto /etc
- newins "${FILESDIR}"/pear.conf-r2 pear.conf
- sed "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf"
- sed "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" -i "${D}/etc/pear.conf"
- sed "s|s:DOWNLOADDIRLEN:\"DOWNLOADDIR\"|s:${#PEAR_DOWNLOADDIR}:\"${PEAR_DOWNLOADDIR}\"|g" -i "${D}/etc/pear.conf"
- sed "s|s:TEMPDIRLEN:\"TEMPDIR\"|s:${#PEAR_TEMPDIR}:\"${PEAR_TEMPDIR}\"|g" -i "${D}/etc/pear.conf"
-
- # Change the paths for eprefix!
- sed "s|s:19:\"/usr/share/php/docs\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/docs\"|g" -i "${D}/etc/pear.conf"
- sed "s|s:19:\"/usr/share/php/data\"|s:$(( ${#EPREFIX}+19 )):\"${EPREFIX}/usr/share/php/data\"|g" -i "${D}/etc/pear.conf"
- sed "s|s:20:\"/usr/share/php/tests\"|s:$(( ${#EPREFIX}+20 )):\"${EPREFIX}/usr/share/php/tests\"|g" -i "${D}/etc/pear.conf"
- sed "s|s:14:\"/usr/share/php\"|s:$(( ${#EPREFIX}+14 )):\"${EPREFIX}/usr/share/php\"|g" -i "${D}/etc/pear.conf"
- sed "s|s:8:\"/usr/bin\"|s:$(( ${#EPREFIX}+8 )):\"${EPREFIX}/usr/bin\"|g" -i "${D}/etc/pear.conf"
-
- [[ "${PEAR_TEMPDIR}" != "/tmp" ]] && keepdir "${PEAR_TEMPDIR#${EPREFIX}}"
- keepdir "${PEAR_CACHEDIR#${EPREFIX}}"
- diropts -m1777
- keepdir "${PEAR_DOWNLOADDIR#${EPREFIX}}"
-}
-
-pkg_preinst() {
- rm -f "${EROOT}/etc/pear.conf"
-}