summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Quota/Quota-1.7.2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-perl/Quota/Quota-1.7.2.ebuild b/dev-perl/Quota/Quota-1.7.2.ebuild
index 9b1c897be014..7e107a67f8fd 100644
--- a/dev-perl/Quota/Quota-1.7.2.ebuild
+++ b/dev-perl/Quota/Quota-1.7.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=TOMZO
-inherit perl-module
+inherit perl-module toolchain-funcs flag-o-matic
DESCRIPTION="Perl interface to file system quotas"
@@ -12,14 +12,19 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND=""
-DEPEND="virtual/perl-ExtUtils-MakeMaker"
+RDEPEND="
+ sys-fs/quota[rpc]
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
# Tests need real FS access/root permissions and are interactive
DIST_TEST=skip
src_prepare() {
default
+ export mymake="OPTIMIZE=$($(tc-getPKG_CONFIG) --cflags libtirpc)"
# disable AFS completely for now, need somebody who can really test it
sed -i -e 's|-d "/afs"|0|' Makefile.PL || die "sed failed"