summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.1.14.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index a06b0fbaebdd..562bbb358ba5 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,3 +1,4 @@
DIST nsd-3.2.22.tar.gz 924627 SHA256 47c2b424c719a1535f709f4e82d796bca43cad86731f5f275c9367040a474a03 SHA512 2c0cbc97eaa376dcf496ed4323d9f7afb0dbf1852fa5fc9d8c7ecbcf8aaa1b025d56b5e439d19bc36b50deaf5f753fb08109d7e25dc1f8223fe85b7d017f81c3 WHIRLPOOL 271b47a331f2a63dd51bf642fed7083f27660f618fe0418c6b3a361d7b0a7ebda1a300d12d92c1c03e21cd17560ba4f2f2cdac76f7c6793d4befc71b66646f7d
DIST nsd-4.1.12.tar.gz 1080273 SHA256 fd1979dff1fba55310fd4f439dc9f3f4701d435c0ec4fb9af533e12c7f27d5de SHA512 f78c0a24669ce8a0cf5640d90f5dfc8756009a840545feddd9c466a5f0b7441d470efb267f7ad38ed45321a6f8b75ad7db9b13bdaefab55b7614ebb3e9bd183b WHIRLPOOL 6304ff6b25a315cf3e340d9cf3cffee141abfdceaeb71ac94c97fe78d14698fe2164042db7785a254feeecd4170c4ad7a8fccdf165cfb5bbefbe1244fdbd4bea
DIST nsd-4.1.13.tar.gz 1085701 SHA256 c45cd4ba2101a027e133b2be44db9378e27602e05f09a5ef25019e1ae45291af SHA512 f355402273480b2befe914ab2e933c37ec35e5c8e747f85ba03bf8928e42ab809bb6b21cf2b8bf11e8d422a795254e1d916b154156243bc94752a01fb540525e WHIRLPOOL f5d7d3386649b82bf2f7eb6ab2f0c50b2f11e4e545931d99352a63317cda127278e5d9219763dc51a5e3a73daa0ab04e45b037eea738cad20cabf284068e9c7c
+DIST nsd-4.1.14.tar.gz 1086818 SHA256 bdfc61c5f3bf11febd8f4776eef1d4f2d95ed70f12f11d4eeee943c186ffd802 SHA512 25d16a6c3e4515129f0ad4f9ab0bf6ebe12bd817cd6107d66cb99aff6b6984f5153d9b502013492cfdd907d5fad9a284583c8436b559ef4c0cce5a1176a4aff3 WHIRLPOOL 64b14e53a13ff379b665c3d76298f4616b05777694b51aa3a6541be7b2c0d6b283fe6f069dec752241393b3e8795ce048ee935f614db39d221962a2d86a693f2
diff --git a/net-dns/nsd/nsd-4.1.14.ebuild b/net-dns/nsd/nsd-4.1.14.ebuild
new file mode 100644
index 000000000000..3719d0f0ac27
--- /dev/null
+++ b/net-dns/nsd/nsd-4.1.14.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit user systemd
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV=${PV/_rc/rc}
+MY_PV=${MY_PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl libressl"
+
+RDEPEND="
+ virtual/yacc
+ libevent? ( dev-libs/libevent )
+ ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:= ) )
+ munin? ( net-analyzer/munin )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+
+src_prepare() {
+ # Fix the paths in the munin plugin to match our install
+ eapply "${FILESDIR}"/nsd_munin_.patch
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --enable-pie \
+ --enable-relro-now \
+ --enable-largefile \
+ --with-logfile="${EPREFIX}"/var/log/nsd.log \
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid \
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db \
+ --with-xfrdir="${EPREFIX}"/var/db/nsd \
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state \
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list \
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd \
+ $(use_enable bind8-stats) \
+ $(use_enable bind8-stats zone-stats) \
+ $(use_enable ipv6) \
+ $(use_enable minimal-responses) \
+ $(use_enable mmap) \
+ $(use_enable nsec3) \
+ $(use_enable ratelimit) \
+ $(use_enable root-server) \
+ $(use_enable runtime-checks checking) \
+ $(use_with libevent) \
+ $(use_with ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+}
+
+pkg_postinst() {
+ # Do this in postinst to ensure the uid/gid is consistent for binpkgs
+ enewgroup nsd
+ enewuser nsd -1 -1 -1 nsd
+
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/lib/nsd
+}