summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/xine-ui/files/xine-ui-0.99.10-libcaca.patch24
-rw-r--r--media-video/xine-ui/xine-ui-0.99.10.ebuild26
2 files changed, 39 insertions, 11 deletions
diff --git a/media-video/xine-ui/files/xine-ui-0.99.10-libcaca.patch b/media-video/xine-ui/files/xine-ui-0.99.10-libcaca.patch
new file mode 100644
index 000000000000..c5a359758d4a
--- /dev/null
+++ b/media-video/xine-ui/files/xine-ui-0.99.10-libcaca.patch
@@ -0,0 +1,24 @@
+diff -r efe11fb1562e configure.ac
+--- a/configure.ac Thu Dec 28 18:08:02 2017 +0200
++++ b/configure.ac Sun Apr 01 23:00:22 2018 -0600
+@@ -374,7 +374,7 @@
+ if test "x$with_caca" = "xyes" && test "x$have_caca" = "xno"; then
+ AC_MSG_ERROR([CACA support requested, but libcaca 0.99 not found])
+ fi
+- if test test "x$have_caca" = "xyes"; then
++ if test "x$have_caca" = "xyes"; then
+ AM_DL()
+ fi
+ AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[#include <caca.h>
+
+--- a/configure Thu Dec 28 18:08:02 2017 +0200
++++ b/configure Sun Apr 01 23:00:22 2018 -0600
+@@ -12651,7 +12651,7 @@
+ if test "x$with_caca" = "xyes" && test "x$have_caca" = "xno"; then
+ as_fn_error $? "CACA support requested, but libcaca 0.99 not found" "$LINENO" 5
+ fi
+- if test test "x$have_caca" = "xyes"; then
++ if test "x$have_caca" = "xyes"; then
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for dlopen in -lc" >&5
+ $as_echo_n "checking for dlopen in -lc... " >&6; }
diff --git a/media-video/xine-ui/xine-ui-0.99.10.ebuild b/media-video/xine-ui/xine-ui-0.99.10.ebuild
index 90ab46eefcff..905b7daa2670 100644
--- a/media-video/xine-ui/xine-ui-0.99.10.ebuild
+++ b/media-video/xine-ui/xine-ui-0.99.10.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
inherit gnome2-utils xdg-utils
DESCRIPTION="Xine movie player"
@@ -13,7 +14,8 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="aalib curl debug libcaca lirc nls readline vdr X xinerama"
-RDEPEND="|| ( app-arch/tar app-arch/libarchive )
+RDEPEND="
+ || ( app-arch/tar app-arch/libarchive )
media-libs/libpng:0=
>=media-libs/xine-lib-1.2:=[aalib?,libcaca?]
virtual/jpeg:0
@@ -35,17 +37,22 @@ RDEPEND="|| ( app-arch/tar app-arch/libarchive )
x11-libs/libXv:=
x11-libs/libXxf86vm:=
xinerama? ( x11-libs/libXinerama:= )
- )"
+ )
+"
DEPEND="${RDEPEND}
+ virtual/pkgconfig
nls? ( >=sys-devel/gettext-0.18.3 )
X? (
x11-base/xorg-proto
x11-libs/libXt
- )
- virtual/pkgconfig"
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-libcaca.patch )
src_prepare() {
- rm -f misc/xine-bugreport
+ default
+ rm misc/xine-bugreport || die
}
src_configure() {
@@ -70,11 +77,8 @@ src_install() {
docdir="/usr/share/doc/${PF}" \
docsdir="/usr/share/doc/${PF}" \
install
- dodoc AUTHORS ChangeLog NEWS README
-}
-pkg_preinst() {
- gnome2_icon_savelist
+ einstalldocs
}
pkg_postinst() {