summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/rsnapshot/Manifest1
-rw-r--r--app-backup/rsnapshot/rsnapshot-1.4.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-backup/rsnapshot/Manifest b/app-backup/rsnapshot/Manifest
index ffdb814c3880..526eb88ace7d 100644
--- a/app-backup/rsnapshot/Manifest
+++ b/app-backup/rsnapshot/Manifest
@@ -1,2 +1,3 @@
DIST rsnapshot-1.4.2.tar.gz 487959 BLAKE2B 90a52af1b2b3de5eae7e98f87b87dae4564a7fa5d240d9e844180d6a57bb4e14b4cf762aa0ed6bbdba8deda0436d77e6c5d281ca8b62eba1c3b6caf948ae9432 SHA512 621be52715a6c1f70ddb251d7f6103ba3487cd0c6c607411d744866547d3ced571862a8f6b5e40a1d050696703f3a15821bd6e829a3fca057848f04566d0e4a0
DIST rsnapshot-1.4.3.tar.gz 370840 BLAKE2B 6a3acde4afd8d1f999cfb00f07a0547b6d877aa483e2548b5ecb933c3f6e742046730a78b95fd83bfa6496a71f61dbce2a8bedc42562503bef753b0c72c40eba SHA512 606b5c195e609197ae6711a9764c07a0f0822fe228aba07014155636bd5caa7ad7dbf8f42316275a71490b5c9dd33bf04c42580b92f4910c38ef871694ae09e3
+DIST rsnapshot-1.4.4.tar.gz 374269 BLAKE2B 1e4a0c99d12d48cf4dacd3817b621f7e6b0ba32e9d9de87b61252875ae0bf735e8ce2c7d8bb60edb2f7d6345a06b183a2616bf1ac3dd7d1b5d3a3ef22a0ede6f SHA512 da45039457b9f3feb53b823f6ee36e8f7447d0689281d1bc857c6fedd450db2fdf8a98e66ba6e135a86654666888f7744ad9ff0aabbd605e1fc09dd5f1f7b838
diff --git a/app-backup/rsnapshot/rsnapshot-1.4.4.ebuild b/app-backup/rsnapshot/rsnapshot-1.4.4.ebuild
new file mode 100644
index 000000000000..6a32d9244d3f
--- /dev/null
+++ b/app-backup/rsnapshot/rsnapshot-1.4.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A filesystem backup utility based on rsync"
+HOMEPAGE="https://www.rsnapshot.org"
+SRC_URI="https://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-lang/perl-5.8.2
+ dev-perl/Lchown
+ >=sys-apps/util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ >=net-misc/openssh-3.7.1_p2-r1
+ >=net-misc/rsync-2.6.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # remove '/etc/' since we don't place it here, bug #461554
+ sed -i -e 's:/etc/rsnapshot.conf.default:rsnapshot.conf.default:' rsnapshot-program.pl || die
+}
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/rsnapshot.conf.default"
+
+ # Change sysconfdir to install the template file as documentation
+ # rather than in /etc.
+ emake install DESTDIR="${D}" \
+ sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
+
+ dodoc README.md AUTHORS ChangeLog \
+ docs/Upgrading_from_1.1
+
+ docinto utils
+ dodoc utils/{README,rsnaptar,*.sh,*.pl}
+
+ docinto utils/rsnapshotdb
+ dodoc utils/rsnapshotdb/*
+}
+
+pkg_postinst() {
+ elog "The template configuration file has been installed as"
+ elog " /usr/share/doc/${PF}/rsnapshot.conf.default"
+ elog "Copy and edit the the above file as /etc/rsnapshot.conf"
+}