summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/dnspython/dnspython-1.16.0-r1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
index c1a63e4d0e3d..f6749205a505 100644
--- a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
+++ b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
@@ -23,6 +23,12 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
!dev-python/dnspython:py2
!dev-python/dnspython:py3"
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/test_resolver.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
pushd tests >/dev/null || die
"${EPYTHON}" utest.py || die "tests failed under ${EPYTHON}"