summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/six/six-1.10.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 9faef64ea365..ed0c5b8e716b 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,6 +26,15 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
+pkg_pretend() {
+ six_dir_check() {
+ local dir="${ROOT}"/$(python_get_sitedir)/six
+ [[ -d "${dir}" ]] \
+ && die "${PN} doesn't work if ${dir} is a directory #546730"
+ }
+ python_foreach_impl six_dir_check
+}
+
python_prepare_all() {
# https://bitbucket.org/gutworth/six/issues/139/
sed \