summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/graphicsmagick/Manifest1
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.26.ebuild134
2 files changed, 0 insertions, 135 deletions
diff --git a/media-gfx/graphicsmagick/Manifest b/media-gfx/graphicsmagick/Manifest
index 70ebde4963bc..c45323e7718d 100644
--- a/media-gfx/graphicsmagick/Manifest
+++ b/media-gfx/graphicsmagick/Manifest
@@ -1,3 +1,2 @@
-DIST GraphicsMagick-1.3.26.tar.xz 5400564 BLAKE2B bd7c5286f4ff0abe8fafee680f9bea5e96c23d1787b5dc5b1a33580b5b8fd2dc8c5932606e0c8f2d783c377104232e8efb6be83ea10e0105c83e9d1925314e0b SHA512 b33ca0f1c858428693aee27a9089acff9e63d1110f85fa036894cfefe6274e7b2422758ea39852f94fdb4823c9c3f3c44b0d8906627503301f5928096f739f22
DIST GraphicsMagick-1.3.27.tar.xz 5412544 BLAKE2B 130ce964f3745f4a9f3b54180529fb45afb4ecc63ecb88f626fa4dd2c6fb54675ff9b5b79527dc89d375cad5c4f1136063e612d91cc9d69b0c330c32c786fd96 SHA512 27c2fccebe1ae079040986979405f9840ad39f773e2e0399712695146ec1b0f92a53533e6052df124f5db38aacc95bbd4b2e8692e81c92dade4e169ddfcc9b8c
DIST GraphicsMagick-1.3.28.tar.xz 5416660 BLAKE2B 874e1e2669db46c458b0e7aa68b24efa07249145b4dd3e1ff2802ec07ad7ea70e4484d0ffcc255454adf4b2be72d6e19f4352db65e22def6e12dfde4cf5987f8 SHA512 c372212e54e6403a44a973113764bf1fee6dde5df08a6ee015ae03c32823f96316018cafd34a355ff8a35ad3581aa7d455d30d664b9d68d3ea2ad277d7cf45e6
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.26.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.26.ebuild
deleted file mode 100644
index 1c81eee7da7f..000000000000
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.26.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools toolchain-funcs
-
-MY_P=${P/graphicsm/GraphicsM}
-
-DESCRIPTION="Collection of tools and libraries for many image formats"
-HOMEPAGE="http://www.graphicsmagick.org/"
-LICENSE="MIT"
-SLOT="0/${PV%.*}"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit mercurial
- EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
-else
- SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
- KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-fi
-
-IUSE="bzip2 cxx debug fpx imagemagick jbig jpeg jpeg2k lcms lzma modules openmp
- perl png postscript q16 q32 static-libs svg test threads tiff truetype
- webp wmf X zlib"
-
-RDEPEND="dev-libs/libltdl:0
- bzip2? ( app-arch/bzip2 )
- fpx? ( media-libs/libfpx )
- imagemagick? ( !media-gfx/imagemagick )
- jbig? ( media-libs/jbigkit )
- jpeg? ( virtual/jpeg:0 )
- jpeg2k? ( media-libs/jasper:= )
- lcms? ( media-libs/lcms:2 )
- lzma? ( app-arch/xz-utils )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng:0 )
- postscript? ( app-text/ghostscript-gpl )
- svg? ( dev-libs/libxml2 )
- tiff? ( media-libs/tiff:0 )
- truetype? (
- media-fonts/urw-fonts
- >=media-libs/freetype-2
- )
- webp? ( media-libs/libwebp:= )
- wmf? ( media-libs/libwmf )
- X? (
- x11-libs/libSM
- x11-libs/libXext
- )
- zlib? ( sys-libs/zlib )"
-# corefonts are required because needed arial font (bug #588398).
-DEPEND="${RDEPEND}
- test? ( media-fonts/corefonts )"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.19-flags.patch
- "${FILESDIR}"/${PN}-1.3.19-perl.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local depth=8
- use q16 && depth=16
- use q32 && depth=32
-
- local openmp=disable
- if use openmp && tc-has-openmp; then
- openmp=enable
- fi
-
- econf \
- --${openmp}-openmp \
- --enable-largefile \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug prof) \
- $(use_enable debug gcov) \
- $(use_enable imagemagick magick-compat) \
- $(use_with threads) \
- $(use_with modules) \
- --with-quantum-depth=${depth} \
- --without-frozenpaths \
- $(use_with cxx magick-plus-plus) \
- $(use_with perl) \
- --with-perl-options=INSTALLDIRS=vendor \
- $(use_with bzip2 bzlib) \
- $(use_with postscript dps) \
- $(use_with fpx) \
- --without-gslib \
- $(use_with jbig) \
- $(use_with webp) \
- $(use_with jpeg) \
- $(use_with jpeg2k jp2) \
- $(use_with lcms lcms2) \
- $(use_with lzma) \
- $(use_with png) \
- $(use_with tiff) \
- $(use_with truetype ttf) \
- $(use_with wmf) \
- --with-fontpath="${EPREFIX}"/usr/share/fonts \
- --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts \
- --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts \
- $(use_with svg xml) \
- $(use_with zlib) \
- $(use_with X x)
-}
-
-src_compile() {
- default
- use perl && emake perl-build
-}
-
-src_test() {
- unset DISPLAY # some perl tests fail when DISPLAY is set
- default
-}
-
-src_install() {
- default
-
- if use perl; then
- emake -C PerlMagick DESTDIR="${D}" install
- find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
- find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
- fi
-
- find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
-}