summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/axel/axel-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/net-misc/axel/axel-9999.ebuild b/net-misc/axel/axel-9999.ebuild
index 70eda56e3f0d..d4a43d0094fd 100644
--- a/net-misc/axel/axel-9999.ebuild
+++ b/net-misc/axel/axel-9999.ebuild
@@ -6,9 +6,9 @@ EAPI=6
inherit autotools git-r3
DESCRIPTION="Light Unix download accelerator"
-HOMEPAGE="https://github.com/eribertomota/axel"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/eribertomota/axel.git"
+EGIT_REPO_URI="https://github.com/axel-download-accelerator/axel.git"
LICENSE="GPL-2"
SLOT="0"
@@ -38,12 +38,19 @@ src_prepare() {
src_configure() {
econf \
$(use_enable nls) \
- $(use_with ssl openssl)
+ $(use_with ssl)
}
pkg_postinst() {
- einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo 'To use axel with portage, create a script in'
+ einfo '/usr/local/bin/fetchwrapper.sh with the following content:'
einfo
- einfo ' FETCHCOMMAND='\''axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' #!/bin/bash'
+ einfo ' set -e'
+ einfo ' /usr/bin/axel -o "$1.axel" "$2"'
+ einfo ' mv "$1.axel" "$1"'
+ einfo
+ einfo 'and then add the following to your make.conf:'
+ einfo ' FETCHCOMMAND='\''/usr/local/bin/fetchwrapper.sh "\${DISTDIR}/\${FILE}" "\${URI}"'\'
einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
}