summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r8.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-boot/grub/grub-2.02_beta2-r8.ebuild b/sys-boot/grub/grub-2.02_beta2-r8.ebuild
index abfeffba89f8..90e03995228d 100644
--- a/sys-boot/grub/grub-2.02_beta2-r8.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r8.ebuild
@@ -309,5 +309,14 @@ pkg_postinst() {
optfeature "Detect other operating systems (grub-mkconfig)" sys-boot/os-prober
optfeature "Create rescue media (grub-mkrescue)" dev-libs/libisoburn
optfeature "Enable RAID device detection" sys-fs/mdadm
+ else
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.02_beta2-r8 ${v}; then
+ ewarn "Please re-run grub2-install to address a security flaw when using"
+ ewarn "username/password authentication in grub."
+ ewarn "See bug 568326 for more information."
+ fi
+ done
fi
}