summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild6
-rw-r--r--dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch27
2 files changed, 31 insertions, 2 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
index 329aec1efb4f..b502e01bf456 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -28,10 +28,12 @@ BDEPEND="
distutils_enable_tests pytest
-# https://github.com/aio-libs/aiohttp-cors/pull/278
PATCHES=(
+ # https://github.com/aio-libs/aiohttp-cors/pull/278
"${FILESDIR}/${P}-tests.patch"
"${FILESDIR}/${P}-py3_7.patch"
+ # https://github.com/aio-libs/aiohttp-cors/pull/412
+ "${FILESDIR}/${P}-py3_11.patch"
)
src_prepare() {
diff --git a/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch b/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch
new file mode 100644
index 000000000000..2dd0df4b61e2
--- /dev/null
+++ b/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch
@@ -0,0 +1,27 @@
+From 1eb2226aaf664d0be746753a32f82ee2e04c2f0b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
+Date: Tue, 1 Mar 2022 15:31:54 +0100
+Subject: [PATCH] Replace @asyncio.coroutine decorator with async def
+
+In Python 3.11 @asyncio.coroutine decorator was removed and it should
+be replaced with async def call.
+
+Fixes: #280
+---
+ tests/unit/test_cors_config.py | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/tests/unit/test_cors_config.py b/tests/unit/test_cors_config.py
+index 817410e..9fe1052 100644
+--- a/tests/unit/test_cors_config.py
++++ b/tests/unit/test_cors_config.py
+@@ -29,8 +29,7 @@ async def _handler(request):
+
+ class _View(web.View, CorsViewMixin):
+
+- @asyncio.coroutine
+- def get(self):
++ async def get(self):
+ return web.Response(text="Done")
+
+