summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
index 170f9004ac00..00346dcd6035 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,14 +7,14 @@ inherit eutils toolchain-funcs
DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
HOMEPAGE="https://www.syslinux.org/"
-# Final releases in 6.xx/$PV.tar.* (literal "xx")
-# Testing releases in Testing/$PV/$PV.tar.*
+# Final releases in 6.xx/${PV}.tar.* (literal "xx")
+# Testing releases in Testing/${PV}/${PV}.tar.*
SRC_URI_DIR=${PV:0:1}.xx
SRC_URI_TESTING=Testing/${PV:0:4}
-[[ ${PV/_alpha} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
-[[ ${PV/_beta} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
-[[ ${PV/_pre} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
-[[ ${PV/_rc} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
+[[ ${PV/_alpha} != ${PV} ]] && SRC_URI_DIR=${SRC_URI_TESTING}
+[[ ${PV/_beta} != ${PV} ]] && SRC_URI_DIR=${SRC_URI_TESTING}
+[[ ${PV/_pre} != ${PV} ]] && SRC_URI_DIR=${SRC_URI_TESTING}
+[[ ${PV/_rc} != ${PV} ]] && SRC_URI_DIR=${SRC_URI_TESTING}
SRC_URI="https://www.kernel.org/pub/linux/utils/boot/syslinux/${SRC_URI_DIR}/${P/_/-}.tar.xz"
LICENSE="GPL-2"