summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pylama/Manifest1
-rw-r--r--dev-python/pylama/pylama-7.6.5.ebuild36
2 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pylama/Manifest b/dev-python/pylama/Manifest
index 3725fe8f84e2..6964008e2ec4 100644
--- a/dev-python/pylama/Manifest
+++ b/dev-python/pylama/Manifest
@@ -1,2 +1 @@
-DIST pylama-7.6.5.tar.gz 33680 BLAKE2B a80d976a6a5e7903f3e4aa6b36777b6a938d52980232d1858bbd602d277bce4b058f8ad404e6dc6692e6950ff36d8e698ff0e3afa44c06334a6bdbe728f15cdd SHA512 0ce2438622cdb3e85fb70d4246cdcc29940181dce82a1a641f6b7900a13f09cba0f871038992019a2e1ccc720dcd6dd5e21786bd8a2df40479a34c500a80fab4
DIST pylama-7.7.1.tar.gz 34740 BLAKE2B a4bd5aed40c2c4e7bdb9f9968030f0954f0309cff80567b2252ee9576fdb4598714286bda63c22676789d4919662430ef2729089faa70b5cb590784eb47ef1f0 SHA512 298fabffcdf38e3e868e3965de87a0e761bc9dfcfe33320b53057c4e05598bcc22045481ec16ccb8df27f49ea41d6fef82b69fe7327905f93ce74d9350682cf0
diff --git a/dev-python/pylama/pylama-7.6.5.ebuild b/dev-python/pylama/pylama-7.6.5.ebuild
deleted file mode 100644
index ff91270e204b..000000000000
--- a/dev-python/pylama/pylama-7.6.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Code audit tool for python"
-HOMEPAGE="https://github.com/klen/pylama"
-SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# pypi tarball excludes unit tests
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-1.5.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/eradicate-0.2[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- >=dev-python/radon-1.4.2[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -v test_pylama.py || die "tests failed with ${EPYTHON}"
-}