summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/configshell-fb/Manifest1
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.24.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 9fa90f359ded..24ccf56c18d7 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1,2 +1,3 @@
DIST configshell-fb-1.1.22.tar.gz 34383 BLAKE2B 2b2f09308552fddc381a931e5e6e6989c8418c99df534ba9ae6ff2631c8953a6ab817a71feb0d1bfc1644fb88f115a413794e88549fe3255828696deef46a340 SHA512 be6fa988ec42014da7e33c5610c2075c04ac7024e64f1c5665a0178d1390356505d69f93d58cc43b602bd26cb4ca28d085b55feafbce90a5dfb57ab26438eea8
DIST configshell-fb-1.1.23.tar.gz 56112 BLAKE2B 7873d5a7ac856aa3c268595063af14db312a1506abe9cd64e69745dba4cf1ebaa0bb098228100c76bed649921e0d5ec614e56631f288eb56f786eba367e3366a SHA512 f657c885889d8714817e6b726aabe13909bc74410d00cdd5aa6c6fba773da3eddfeb7c08699292406d0c1f58bb0417da41fdfeadeff8de5107c52d953bb9e468
+DIST configshell-fb-1.1.24.tar.gz 56946 BLAKE2B ddda3313bb41a346d08006f1d3c1cdc708a940ab9fb2e0042896947b89e32cca872fc8a19a392eeebbc6403f042aadcef2c78962c069e9c1ed10a2f5d4bb102f SHA512 34aabe6fa5c2f00112748e35fe3859fae09baac5ef13b9aa80e6f00908290a0d724119aa3b2ce86da8bb171c60860304e650aeb16bc678354a7464bd0b5c9b48
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.24.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.24.ebuild
new file mode 100644
index 000000000000..16152005bc40
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.24.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ !dev-python/configshell"