summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/sshuttle/Manifest1
-rw-r--r--net-proxy/sshuttle/metadata.xml2
-rw-r--r--net-proxy/sshuttle/sshuttle-0.73.ebuild34
3 files changed, 36 insertions, 1 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index 79dba7b4164d..f28f2b9e86ed 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1 +1,2 @@
DIST sshuttle-0.61.tar.xz 181528 SHA256 78cea312c4bab6f6baa459131cb7739d9fae7d0df9e54efd48fc4ddd852042f5 SHA512 39687ecf0a9b78cc0f7dc576c3c036f5afb52050f17d793602e50c8a9ab8bb0f9eb3277cb2fffb1e9c0f5f652d96c6915aecf8a8da93697172d8cbef1161a986 WHIRLPOOL 9c8597d98306730fcab750094588310c03bafea473b54a2758e055a7bb4bb851b3edad4d2cf2995893a30ed4148b7fd8437820099042ff6c7c52a0dc279d6ebc
+DIST sshuttle-0.73.tar.gz 53321 SHA256 d78a6aa76f93ab69fd9685ce11b428a9b549c049a6c0104740c06c9b354a5ae3 SHA512 75bef9f0472cf648454fbde6d6fb14e0656e5d84896cf3295e8535a4cf6859bdafd0053d65ebb673da46e0bcb422dd1a615deef026c2eefd67a4702e70dd3660 WHIRLPOOL c07745df347e68326e211939db0fb8f0eac862cd7f1035b4e3424f3ad6bc9509a558508e8af77e2aaef290e694d871227d3f5a569ae444bc67457419a988b9f1
diff --git a/net-proxy/sshuttle/metadata.xml b/net-proxy/sshuttle/metadata.xml
index be10143d3fe7..f932a942b220 100644
--- a/net-proxy/sshuttle/metadata.xml
+++ b/net-proxy/sshuttle/metadata.xml
@@ -6,6 +6,6 @@
<name>Tim Harder</name>
</maintainer>
<upstream>
- <remote-id type="github">apenwarr/sshuttle</remote-id>
+ <remote-id type="github">sshuttle/sshuttle</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-proxy/sshuttle/sshuttle-0.73.ebuild b/net-proxy/sshuttle/sshuttle-0.73.ebuild
new file mode 100644
index 000000000000..1ff6ebfff3fe
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-0.73.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_5} )
+
+inherit eutils linux-info distutils-r1
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-firewall/iptables
+"
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~NF_NAT"
+
+python_test() {
+ py.test || die "Tests fail under ${EPYTHON}"
+}