summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.0.0.ebuild40
-rw-r--r--media-sound/flacon/Manifest1
-rw-r--r--media-sound/flacon/flacon-9.0.0.ebuild84
-rw-r--r--media-sound/flacon/metadata.xml9
5 files changed, 134 insertions, 1 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 1383b79992bf..9d240d95d458 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1 +1,2 @@
DIST pytest-bdd-5.0.0.gh.tar.gz 61174 BLAKE2B 6dd1d53614226d3515b0f61f71822363b559aa45789bab7f3416c75e603e87a1fe48627f36862f44bfa7ac6ec5023ad8afde6054ec67fc9a2e756be7de729fd1 SHA512 827e57d410b05207b6c646062ddb54b677e22441311820d3bd406df202b6e9344dedf59cd4868e89cfbf8606fe3f15559e4cc3958d100e4fa74f9b864e6faada
+DIST pytest-bdd-6.0.0.gh.tar.gz 60475 BLAKE2B 48d09d5f5a4f274a27239a33f354aa52b1ebafc904ddc1dbb331d830f8cfabe0ba748d1fe6dadaf32f5b4848e1761d2dea1a06ac5b9d5f0c0e15e3248586cf42 SHA512 5223190a1b1d80761059cc34893b64eeca6c4d35b3a81aed186b5d1b4214ac67660cfa6cd39e1953a445c8ca7ceea74cb32b224435193febad35433c2eaf3266
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.0.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.0.0.ebuild
new file mode 100644
index 000000000000..2e99002d0b45
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-6.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/glob2[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}
diff --git a/media-sound/flacon/Manifest b/media-sound/flacon/Manifest
index a862fd500a7f..e64519db3b62 100644
--- a/media-sound/flacon/Manifest
+++ b/media-sound/flacon/Manifest
@@ -1,2 +1,3 @@
DIST flacon-5.5.1.tar.gz 2336502 BLAKE2B 524fe5fa28126f56452515ca1ce1572343dad8b06c28fc8e3a22a11e9ad8f3a51a25b3c19ddd29a7e3c658f1d7fb3316a2554a12a4ba3dd22370fc1394d38022 SHA512 36900b011135b61cf3cc1f05d94f852fc7e127972f3fed09e0fb7e66fec944ed1c3bfc61307494aff87c2fe24e16479605043a79e0634bc23940d01fc337c6c1
DIST flacon-8.2.0.tar.gz 3757221 BLAKE2B dff0dc849c326a53ad167efea3106ca2d057121081822a821f2daa4cc2140a858960f1b4cdc2935f3e569aac25c25ceece2d171056788b9f541355c540457550 SHA512 9799c1a27426a2f67d782f15a3a1d210c5dc61b00b30b9c4143047a243f2d46cb0eb651c18919fa1ac2a8fdc2f54c83ec2e0b46a00254c908230e7ffb34965bc
+DIST flacon-9.0.0.tar.gz 3762192 BLAKE2B abebc21e31fee43f4970b6e56724bfb0b6f2cc7d33e2539def102b329f1228886f7f0fcbb20a2e100a7ba77f6f45bf5ac032151ab0f830676dbf4ce24da0ce3f SHA512 3780f94a4c6c6812eb0a0efd4e677926d8cc53c15f692701cd20df0441f551d4639b632c08a36146873ad11cdb9cdaa4e726845eb05ae15ecc29a1dac250a928
diff --git a/media-sound/flacon/flacon-9.0.0.ebuild b/media-sound/flacon/flacon-9.0.0.ebuild
new file mode 100644
index 000000000000..ed4cffb9c113
--- /dev/null
+++ b/media-sound/flacon/flacon-9.0.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests require lots of disk space
+CHECKREQS_DISK_BUILD=10G
+inherit check-reqs cmake optfeature virtualx xdg-utils
+
+DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
+HOMEPAGE="https://flacon.github.io/"
+SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-i18n/uchardet
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ test? (
+ dev-qt/qttest:5
+ media-libs/flac
+ media-sound/mac
+ media-sound/shntool
+ media-sound/ttaenc
+ media-sound/wavpack
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ use test && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use test && check-reqs_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx "${BUILD_DIR}/tests/${PN}_test" || die
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} optionally supports formats listed below."
+ optfeature 'FLAC input and output support' media-libs/flac
+ optfeature 'WavPack input and output support' media-sound/wavpack
+ optfeature 'APE input support' media-sound/mac
+ optfeature 'ALAC output support' media-sound/alac_decoder
+ optfeature 'TTA input support' media-sound/ttaenc
+ optfeature 'AAC output support' media-libs/faac
+ optfeature 'MP3 output support' media-sound/lame
+ optfeature 'Vorbis output support' media-sound/vorbis-tools
+ optfeature 'MP3 Replay Gain support' media-sound/mp3gain
+ optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain
+
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/media-sound/flacon/metadata.xml b/media-sound/flacon/metadata.xml
index 39b7db36d101..0c5a1c0fb135 100644
--- a/media-sound/flacon/metadata.xml
+++ b/media-sound/flacon/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>rndxelement@protonmail.com</email>
+ <name>Philipp Rösner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">flacon/flacon</remote-id>
</upstream>