summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/raspberrypi-userland-bin/Manifest1
-rw-r--r--media-libs/raspberrypi-userland-bin/files/04raspberrypi-userland-bin1
-rw-r--r--media-libs/raspberrypi-userland-bin/metadata.xml12
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild49
4 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/Manifest b/media-libs/raspberrypi-userland-bin/Manifest
new file mode 100644
index 000000000000..bacb97efe086
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/Manifest
@@ -0,0 +1 @@
+DIST raspberrypi-firmware-1.20160209.tar.gz 114792438 SHA256 ca6a88db72e90ef821b8ca7755bbee9c1d5bdb9a621a45eb029af195d2d29751 SHA512 281092c11d422d821e5e2b0479c3b8f891f8df66cfbf931992902d759c99ed40cbb2d9fada1f944372e5bcd8af69784739e79e9912db3482892b10bf668611f2 WHIRLPOOL 81974a53562ee91544d7a01dc9f4f4173a6e882891f8cf744b700162ddd8f8607b1cfcbbde04cafe2bcea47489f9ea4fd8840adf776e806bef0dba574448e76e
diff --git a/media-libs/raspberrypi-userland-bin/files/04raspberrypi-userland-bin b/media-libs/raspberrypi-userland-bin/files/04raspberrypi-userland-bin
new file mode 100644
index 000000000000..d4d8fad4cc83
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/files/04raspberrypi-userland-bin
@@ -0,0 +1 @@
+LDPATH='/opt/vc/lib'
diff --git a/media-libs/raspberrypi-userland-bin/metadata.xml b/media-libs/raspberrypi-userland-bin/metadata.xml
new file mode 100644
index 000000000000..a0cb81f5a6f6
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+<use>
+ <flag name="hardfp">Use armv6 hardfp ABI</flag>
+</use>
+</pkgmetadata>
+
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild
new file mode 100644
index 000000000000..b7b3c7b90cf9
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20160209.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit multilib vcs-snapshot
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_P="raspberrypi-firmware-${PV}"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="binchecks"
+
+src_prepare() {
+ rm {,hardfp/}opt/vc/LICENCE || die
+}
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+ into /opt
+ dobin bin/*
+ dobin sbin/*
+ insopts -m 0755
+ insinto "/opt/vc/$(get_libdir)"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/hello_pi
+ fi
+}