summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/minikube/Manifest1
-rw-r--r--sys-cluster/minikube/minikube-0.20.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/minikube/Manifest b/sys-cluster/minikube/Manifest
index 5ff01f5dd428..1eb1d1c63c3b 100644
--- a/sys-cluster/minikube/Manifest
+++ b/sys-cluster/minikube/Manifest
@@ -1 +1,2 @@
DIST minikube-0.19.1.tar.gz 16578098 SHA256 5b5c0076620ed29e7a9d446537873248a72cb117f544024082e3b089bb47d38a SHA512 00cf342a628e6b67ab579a71f86af2113cbe6cb0f0759616894a5107b1bf2610a7564924fa6f531d9a68ee126bd3132f612d811f84a15579a3bdedcf783a7d91 WHIRLPOOL ce7f5763ca53f58ce7e8d9665d131b5132857bd91de1dca8c44b04c6212eeac497fe54b4ecf2af321ab3d21aac56d2d7a6ca4964ed26a9667eb01f5eb33fb532
+DIST minikube-0.20.0.tar.gz 16581668 SHA256 91a52aa995c5104c0ce39563082421f99e214cb7a47453c150c7e2c4dfc74231 SHA512 2b20f2f6109652144db92299541627637032f2882886e590065248cf35f77632fb7fcb157258b2306b871bfd072b00341c0f82b941264f1c7f87bea6029b118f WHIRLPOOL e1b6a023025705522a91abf496d0b65ec36a1181160579b80a8a73d0f1f1d00361e60a1ce0e7bca3953580f901da7da444df92da2d3da6fd79a0ab50eaf17b6a
diff --git a/sys-cluster/minikube/minikube-0.20.0.ebuild b/sys-cluster/minikube/minikube-0.20.0.ebuild
new file mode 100644
index 000000000000..52263b1bebca
--- /dev/null
+++ b/sys-cluster/minikube/minikube-0.20.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-any-r1 golang-build golang-vcs-snapshot
+
+EGO_PN="k8s.io/minikube"
+ARCHIVE_URI="https://github.com/kubernetes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Single Node Kubernetes Cluster"
+HOMEPAGE="https://github.com/kubernetes/minikube https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+DEPEND="dev-go/go-bindata
+ ${PYTHON_DEPS}"
+RDEPEND=">=sys-cluster/kubectl-1.6.4"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e 's/ -s -w/ -w/' -e 's#$(GOPATH)/bin/go-bindata#go-bindata#' -e 's#GOBIN=$(GOPATH)/bin go get github.com/jteeuwen/go-bindata/...##' src/${EGO_PN}/Makefile || die
+ sed -i -e "s/get_rev(), get_version(), get_tree_state()/get_rev(), get_version(), 'gitTreeState=clean'/" src/${EGO_PN}/hack/get_k8s_version.py || die
+}
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -C src/${EGO_PN}
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin out/minikube out/localkube
+ dodoc -r docs CHANGELOG.md README.md
+ popd || die
+}