summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-cflags.patch23
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild3
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-cflags.patch b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-cflags.patch
new file mode 100644
index 000000000000..2006c7d711ef
--- /dev/null
+++ b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-cflags.patch
@@ -0,0 +1,23 @@
+don't clobber the user's settings that configure already put together for us
+
+--- a/libhfsp/src/Makefile.am
++++ b/libhfsp/src/Makefile.am
+@@ -27,7 +27,5 @@
+ blockiter.c btree.c btreecheck.c fscheck.c hfstime.c libhfsp.c os.c unicode.c \
+ record.c volume.c partitions.c
+
+-CFLAGS = -O2 -Wall
+-
+ # I need to clean up these headers first before i can distribute them ...
+ # include_HEADERS = apple.h hfs.h hfsp.h libhfsp.h
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -8,8 +8,6 @@
+
+ INCLUDES = -I../libhfsp/src
+
+-CFLAGS = -O2 -Wall
+-
+ bin_PROGRAMS = hpmount hpumount hpls hpcd hpcopy hppwd hpfsck hprm hpmkdir
+
+ hpmount_SOURCES = hpmount.c hpcache.c hfsputil.c glob.c dstring.c dlist.c
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
index 380d9b293094..fd1d77c39579 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
@@ -26,8 +26,11 @@ src_prepare() {
epatch "${FILESDIR}/${P}-gcc4.patch"
epatch "${FILESDIR}/${P}-string.patch"
epatch "${FILESDIR}/${P}-stdlib.patch"
+ epatch "${FILESDIR}/${P}-cflags.patch"
# let's avoid the Makefile.cvs since isn't working for us
eautoreconf
+
+ append-flags -fgnu89-inline
}
src_install() {