summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libde265/libde265-1.0.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/libde265/libde265-1.0.2.ebuild b/media-libs/libde265/libde265-1.0.2.ebuild
index 7b52f0011412..e13236350412 100644
--- a/media-libs/libde265/libde265-1.0.2.ebuild
+++ b/media-libs/libde265/libde265-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,6 +27,11 @@ RDEPEND="${DEPEND}"
REQUIRED_USE="tools? ( || ( qt4 qt5 ) )"
+src_prepare() {
+ sed -ri 's/(PIX_FMT_)/AV_\1/g' sherlock265/VideoDecoder.cc || die
+ autotools-multilib_src_prepare
+}
+
src_configure() {
local myeconfargs=(
$(use_enable cpu_flags_x86_sse sse)