summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-5.5.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 9d19f8ef68d2..12fd6402fa0a 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,2 +1,3 @@
DIST tortoisehg-5.3.2.tar.gz 8910859 BLAKE2B 4cc2253f0adbd79fe84507043491198ddd9fa559c3e9296c831b8e0fccd6cb2806a31ffd6d417591f5fcb3afce78e696f7052d70b760a566bf72c6602ca31ea8 SHA512 b15894158a0d5e628015d07b4f8c77c96f3e1d7543fe2984693b99b2acfa411922b06683e62de437cb50dd5817155d4e59045d7fb47c9be8ee27b9bccf77da7e
DIST tortoisehg-5.4.1.tar.gz 8580608 BLAKE2B db66e114d046fdf2228779a2e224c6244afe4e6463d8f00b7f3b291f0dc9fd043ca3e938a6769e3c6a54ec4d2252dca44fedf790ca9683fa42a55d0cdfce0cb9 SHA512 f8d4bda4ac23b49f304e3561930b75f899ac09937b4da446ee3f38236fa0095e19228dc2e388d5608077096209ded161d194f6edef5d2d4a257b5bf57c0634cc
+DIST tortoisehg-5.5.1.tar.gz 8918085 BLAKE2B 33aef61d97a34f45b10b291eb3a71bc46b70a1f24006fda0e651e88c61b0351701a3abdf6c1b0277fd81a0c5c9ff225b742215103c280eb11976a86e6bf2a47c SHA512 ca2d3833e379620b1a467b5a6016c8dbd54837d6ac5267063eb6768675dcb0c020a9b4ca2b2b8924a57c9e7d117668347e23762e8ff46c87825290071783aaa8
diff --git a/dev-vcs/tortoisehg/tortoisehg-5.5.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-5.5.1.ebuild
new file mode 100644
index 000000000000..fd6e1dce5cd4
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-5.5.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://www.mercurial-scm.org/release/tortoisehg/targz/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-5.4
+ <dev-vcs/mercurial-5.6"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-5.4"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ ${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5:=[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}