summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libofx/Manifest1
-rw-r--r--dev-libs/libofx/files/libofx-0.9.5-gcc47.patch11
-rw-r--r--dev-libs/libofx/libofx-0.9.5.ebuild47
3 files changed, 0 insertions, 59 deletions
diff --git a/dev-libs/libofx/Manifest b/dev-libs/libofx/Manifest
index 8939ecdc7a46..32f190d71c1d 100644
--- a/dev-libs/libofx/Manifest
+++ b/dev-libs/libofx/Manifest
@@ -1,2 +1 @@
DIST libofx-0.9.10.tar.gz 1433837 SHA256 54e26a4944ef2785087cfd8ed8f187ab9d397d9b92b5acc199dd7d5d095cf695 SHA512 061110702034dbbb9be3adaebe6236a4b0842169d8ee7671bad6c93960b380cbb33953bdf080c8b14f45930b0c817fcfe1bf71f15d9872dd2535a1415f5be895 WHIRLPOOL 2cf39474bde30086b51529d4fccae51c6b1728b413ddf45768283e1404d0b8bb0316a532c3a1436dfee22d4953df8ef42470bf4414cbd1aef7b9fb7c8661ce38
-DIST libofx-0.9.5.tar.gz 1526857 SHA256 a075c5634b94bad16f8c949eeb77625d31bedea3bb10a8da174b989ffab7e78e SHA512 f7c6e0d85ee1f01216678ec51939ffe09c4a4c5ccc97a5928be45bd2be27418a95004a8a46f17225366908cdd8bb43b19bf95295f0e6422802d3a935a63eb0a9 WHIRLPOOL 67f61361417636e297f45f7c9d3d4de9e88a20c9af4b1a6f811d4b6d6d671f045f3f485b193d24372e89fdbfbd944565bb3ec224578351c1d31cf9c109921d5f
diff --git a/dev-libs/libofx/files/libofx-0.9.5-gcc47.patch b/dev-libs/libofx/files/libofx-0.9.5-gcc47.patch
deleted file mode 100644
index 2e6ee8b08d65..000000000000
--- a/dev-libs/libofx/files/libofx-0.9.5-gcc47.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN libofx-0.9.5.orig/ofxconnect/ofxpartner.cpp libofx-0.9.5/ofxconnect/ofxpartner.cpp
---- libofx-0.9.5.orig/ofxconnect/ofxpartner.cpp 2011-03-31 00:30:50.000000000 +0200
-+++ libofx-0.9.5/ofxconnect/ofxpartner.cpp 2012-06-30 21:57:35.747989782 +0200
-@@ -37,6 +37,7 @@
- #include <vector>
- #include <algorithm>
- #include <string.h>
-+#include <unistd.h>
-
- using std::string;
- using std::vector;
diff --git a/dev-libs/libofx/libofx-0.9.5.ebuild b/dev-libs/libofx/libofx-0.9.5.ebuild
deleted file mode 100644
index ec7f03d27b96..000000000000
--- a/dev-libs/libofx/libofx-0.9.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit base
-
-DESCRIPTION="A library to support the Open Financial eXchange XML format"
-HOMEPAGE="http://libofx.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ~ppc ~ppc64 x86"
-IUSE="doc static-libs test"
-
-RDEPEND=">=app-text/opensp-1.5
- dev-cpp/libxmlpp:2.6
- >=net-misc/curl-7.9.7"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( sys-apps/help2man )
- test? ( app-crypt/gnupg )"
-
-PATCHES=( "${FILESDIR}/${P}-gcc47.patch" )
-
-src_prepare() {
- base_src_prepare
- # Be sure DTD gets installed in correct path after redefining docdir in install
- sed -i \
- -e 's:$(DESTDIR)$(docdir):$(DESTDIR)$(LIBOFX_DTD_DIR):' \
- dtd/Makefile.in || die
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- --disable-doxygen
-}
-
-src_install() {
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
-
- rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,INSTALL}
- find "${ED}" -name '*.la' -exec rm -f {} +
-}