summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/netdata/netdata-1.20.0.ebuild13
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild13
2 files changed, 14 insertions, 12 deletions
diff --git a/net-analyzer/netdata/netdata-1.20.0.ebuild b/net-analyzer/netdata/netdata-1.20.0.ebuild
index 2e1eb0f4a276..38d285c386ee 100644
--- a/net-analyzer/netdata/netdata-1.20.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.20.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit autotools fcaps linux-info python-r1 systemd
+inherit autotools fcaps linux-info python-single-r1 systemd
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
@@ -63,15 +63,15 @@ RDEPEND="
)
python? (
${PYTHON_DEPS}
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]')
mysql? (
|| (
- dev-python/mysqlclient[${PYTHON_USEDEP}]
- dev-python/mysql-python[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]')
+ $(python_gen_cond_dep 'dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]')
)
)
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- tor? ( net-libs/stem[${PYTHON_USEDEP}] )
+ postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}]') )
+ tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_MULTI_USEDEP}]') )
)
xen? (
app-emulation/xen-tools
@@ -85,6 +85,7 @@ FILECAPS=(
)
pkg_setup() {
+ use python && python-single-r1_pkg_setup
linux-info_pkg_setup
}
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 2e1eb0f4a276..38d285c386ee 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit autotools fcaps linux-info python-r1 systemd
+inherit autotools fcaps linux-info python-single-r1 systemd
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
@@ -63,15 +63,15 @@ RDEPEND="
)
python? (
${PYTHON_DEPS}
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]')
mysql? (
|| (
- dev-python/mysqlclient[${PYTHON_USEDEP}]
- dev-python/mysql-python[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]')
+ $(python_gen_cond_dep 'dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]')
)
)
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- tor? ( net-libs/stem[${PYTHON_USEDEP}] )
+ postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}]') )
+ tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_MULTI_USEDEP}]') )
)
xen? (
app-emulation/xen-tools
@@ -85,6 +85,7 @@ FILECAPS=(
)
pkg_setup() {
+ use python && python-single-r1_pkg_setup
linux-info_pkg_setup
}